1 Reply Latest reply on Aug 29, 2009 1:51 AM by oobi

    CF 8 Debugging with Eclipse

    torstenp Level 1
      I have loaded up eclipse 3.3 with the proper cold fusion files (from the forta site and not adobe) -- created the RDS connections. Both the test connection and test debugger come up successful. I can go into the debugger perspective and start the debugging. The debugger launches. I get the server name and ColdFusion template graphic in debug window. All looks like its working correctly.
      I open a simple document with just some cfset and a cfloop on it - set several breakpoints.
      run the page on my server and in the debug output bugger and the page just runs to completion.
      nothing is trigger in the eclipse.

      the debugging is turn on, on the server (or it wouldnt even let me get that far in eclipse w/o errors)
      using the default port.
      my page timeout in cf admin is unchecked.

      we run IIs on windows 2003.
      laptop running XP

      Any help and ideas would be greatly appreciated - as i am running out of online help.
      i have gone through 3 setups per 3 different websites including the chapter in forta's book.

        • 1. Re: CF 8 Debugging with Eclipse
          oobi

          Did you ever work out what the problem was? I've hit the same wall.

           

          My RDS works fine (I can browse data sources etc). "Test Debugger" and "Test Connection" buttons both come back with success. I'm running through Linux/Apache webserver so I have set the RDS server port to 80 (as opposed to 8500 for the internal webserver). My pages also run to completion despite being riddled with breakpoints. I have of course tried 80 and 8500 for as the port, but neither gives me any result.

           

          I added this parameter to my JVM config (as suggested in Adobe's docs) to see what was going on

          -DDEBUGGER_TRACE=true

           

          When I fire up a debug session I get this appearing in the server log:

           

          ------------------------------------------------------------------

          RDSRequest - DBG_REQUEST,1251534475327,<wddxPacket version='1.0'><header/><data><array length='1'><struct><var name='BREAK_ON_EXCEPTION'><boolean value='false'/></var><var name='COMMAND'><string>SESSION_BREAK_ON_EXCEPTION</string></var></struct></array></data>< /wddxPacket>,user,52194229261e48,

           

          RDSResponse -

          ------------------------------------------------------------------

           

          The response part is always blank. That at least tells me that the eclipse bits are communicating with the coldfusion server, but it's not doing much else.

           

          Interestingly when going through what I could find in forums I found references to unticking the box labelled "break on CFML runtime exception". Mine was unticked by default but for giggles I tried ticking it and throwing exceptions in the test code - no response. However (and this is the weird bit) I loaded up CF admin via http://server:8500/CFIDE/administrator and it caught some exception in the admin page and started stepping the login page.

           

          From this I can only surmise that somehow the debugger is only working (or configured) for the coldfusion built-in webserver. Unfortunately I can't find reference to any documentation that suggests any different setting to what I have already.

           

          I did think that perhaps the problem was a bad mapping, but I've tried every permutation of the local/remote paths I can think of (UNC, drive mapping etc). None of that makes any difference, and it was able to lock onto the CF admin login page without any such mapping.

           

          Any ideas?