2 Replies Latest reply on Oct 23, 2017 7:12 PM by anascotney

    Mac with OS X ver 10.10.5 not meeting min system requirements

    anascotney

      Hi There, I am writing because I am unable to download the most up to date version of Adobe Premier Pro cc ver. 12.0 2017 as of September 2017 which I require to open and continue editing existing film projects in this version of premier.  I am attempting to download this programme on an apple macbook pro, which has OS X ver. 10.10.5. I have purchased and renewed my subscription to adobe creative cloud, uninstalled my old version of premier pro as it was from 2014 and was around version 7.0, and have attempted to download the most up to date version, however, it says that my computer does not meet the minimum system requirements. When I have checked my system requirements, it has looked as though my computer meets all of them. What is the cause of this, and how can i fix it?

       

      Best wishes, Ana Scotney.