6 Replies Latest reply on Oct 27, 2017 6:05 AM by Finatic

    Camera Not Working Properly Help?

    Finatic

      Ever Since I have updated after effects to 2018 version. Everything seems to be failing. and it is very frustrating. to start the issue I am having along with many others is the Camera. This is going to be hard to explain so ill have to show with images. In between the 2 red key frames the settings are set to the same settings which means I do not want any movement at all. Then when I apply the new animation keyframes. All 3 sections of keyframes have movement. It is absolutely frustrating this has never happened to me before until this version of 2018. It's bad enough I was told about a glitch I cannot fix which is also in an image below maybe someone has an Idea. I have been using this program for little more of 3-4 years. Yes I am Using plug ins. Yes I am using 3rd Party Fonts. Yes I am using some scripts. also Yes my computer can handle it without a doubt. Lol If anyone has any suggestions would be great.

       

       

      Build: Element x64 2.2.2 (2155.hotfix)

      OS: Microsoft Windows 10 Home 64-bit 10.0.15063

      CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz

      RAM: 65451MB

      GPU Vendor: NVIDIA Corporation

      GPU: GeForce GTX 1070/PCIe/SSE2

      GPU Driver: 23.21.13.8800

      GPU RAM: 8192MB

      GPU Code: 0

      CL0: GeForce GTX 1070 (50.0%) (GL Interop)

      CL1: GeForce GTX 1070 (50.0%)

       

      This image is my 2nd problem overlapping font.

      Numbers overlapping.jpg

      Camera Image.jpg

        • 1. Re: Camera Not Working Properly Help?
          cbialk Level 2

          For the overlapping font, I had the same issue with After Effects on a system with a 4K monitor - - set to scale resolution to 150% in the Windows Display settings. I changed my windows scaling to a non-standard variable: 138% and it fixed the overlapping. That fix does introduce some other Windows quirks, especially with dual monitors, but it made AE usable again for me.

          1 person found this helpful
          • 2. Re: Camera Not Working Properly Help?
            Finatic Level 1

            You are correct on the scaling it did solve the issue. I am on 2 4K usually only have one activated because Element 3D and After effects only recognize 8gb of the 16gb Vram I have installed. So tried it and it fixed it but Isn't this an update issue with after effects? cause nothing changed and my 4K monitors worked fine on the 2017 copy. just started on the new update this issue occurred. Oh and also after a fix for the Camera issue if anyone can still help

            • 3. Re: Camera Not Working Properly Help?
              Rick Gerard Adobe Community Professional & MVP

              The movement between keyframes is caused by bezier interpolation. Change the interpolation to linear to stop the movement between two identical keyframes. This is a common issue when you don't use linear interpolation between motion keyframes. Bezier motion is usually more pleasing.

               

              The other solution is to use a hold keyframe. Do a little research in the help files on keyframe interpolation by using the search help field at the top right corner of AE. Right click on your keyframes to change interpolation and a bunch of other keyframe properties.

              • 4. Re: Camera Not Working Properly Help?
                Finatic Level 1

                I had the default settings at Linear in general. and I checked each key frame in question in the keyframe interpolation and they were all set to linear. The Camera was still reacting the same way.I even spent time messing with the other settings to see if it would fix it unfortunately no. Hold frame was a method I tried multiple times and it still did not react. I checked the forum and couldn't see anything else for this matter. I have already reinstalled now but still nothing

                • 5. Re: Camera Not Working Properly Help?
                  Rick Gerard Adobe Community Professional & MVP

                  If you are getting rebound or ping-pong between two identical keyframes then you do not have temporal or spatial interpolation set to linear. It's that simple.

                   

                  Select the position property of one of your layers, make sure you are showing all keyframes in preferences, use a view that lets you see the motion and carefully check the motion path and I will bet that you see the rebound. You can choose the pen tool and click on one of the points that have bezier handles while holding down the Alt/Option key and remove all movement between keyframes.

                   

                  This is not a bug, it's user error. I see it all the time.

                   

                  A screenshot of the graph editor or a close up of the motion path where you are getting the rebound will also show the problem. Here's a simple animation showing the position keyframes and the bezier handles and the value of the second keyframe and the third so you can see they are identical. The motion ping-pong's between the second and third keyframes.

                  Screen Shot 2017-10-26 at 9.57.36 PM.png

                  This is the same animation with the CTI a little farther down the timeline and I have removed the bezier handles by using the Pen Tool and selecting both keyframes in the Comp Panel while holding down the Alt/Option key. No more bezier handles, no more ping pong.

                   

                  You can do exactly the same thing using the graph editor or using keyframe interpolation or keyframe velocity. It's all just a matter of knowing how to manipulate the keyframes.

                  Screen Shot 2017-10-26 at 9.58.22 PM.png

                  Prove me wrong by showing a screenshot that shows no bezier handles on the motion path and identical pair of keyframes that still gives you a rebound.

                  • 6. Re: Camera Not Working Properly Help?
                    Finatic Level 1

                    So this is just for one project I have spacial path defaulted to linear. and I have checked each keyframes interpolation and they are set to Linear. I know this is user error and is common cause I ran into this problem about a year ago with 2017 same thing but was an easy solve. this time I think it may Have something to do with Element 3D or TypeMonkey. i didn't have time to animate over 200+ text layers. and TypeMonkey seems to maybe be causing the disconnect even know I chose to have No Camera attached to the TypeMonkey Layer. Once I deleted the layer and just used the Straight Camera over the element 3D Layer I have no Issue. When I checked the control layer for TypeMonkey it shows no movement either. so I just find it extremely odd. That the Camera will only Ping Pong when TypeMonkey Is activated. I will have a look when I am home at your suggestions and see if I can resolve the issue. This composition is now too large to open on my laptop.