4 Replies Latest reply on Nov 8, 2017 4:33 PM by JimHess

    Minimum System requirements?

    malcolmglennie

      I can't see the option for Color and Luminance Range Masking tool and from another thread I read that you have to update to the latest process versions

       

      [QUOTE]If you're only seeing the older process versions as years, with 2012 labeled as current, it sounds like you might still be in Lr CC 2015 (6.x). Can you confirm that you are using the new Lr Classic CC (7.0) when you are seeing the old process versions?[/QUOTE]

       

      So I tried to download Lightroom Classic CC

       

      This computer does not meet the minimum system requirements for Lightroom CC. Please refer to the system requirements in the Help documentation for a full list of hardware and software requirements for Lightroom CC.

       

      Processor - 3.3 GHz Intel Core i5

      Memory - 32 GB 1867 MHz DDR3

      Graphics - AMD Radeon R9 M290 2048 MB

       

      any help appreciated