3 Replies Latest reply on Nov 9, 2017 8:44 AM by rasterdan

    Project keeps getting removed from RoboSource Control 3.1

    rasterdan

      We have a project that keeps getting removed from RSC.  I just made a new folder, pulled a clean copy, put a space in a topic to verify it would check out, all ok.  Rebooted my computer and attempted to open the same project and it indicates it has been removed from version control.

      • We just upgraded to RH 2017 a few weeks back. 
      • We added a new user.
      • We installed the RSO3 middle tier patch to the new computer.
      • All of us are running Windows 7 64.
      • All of us have RH2017.
      • 2 of us are coming in via VPN.
      • None of these problems occurred (even with this project) prior to RH2017.
      • Haven't tried to see what the person local to the server see's when he opens the project but that would potentially open a different issue since he has not worked on this project.
      • If I add to version control after opening the project it goes strangely fast and then the other person is prompted with "project has been removed from version control."
      • We are both deleting our .cpd file when the project opens (check box in setup is checked).

      Any ideas??

       

      Thanks,

      dv

        • 1. Re: Project keeps getting removed from RoboSource Control 3.1
          Amebr Level 4

          Make sure you haven't got the cpd, pss, or ldb checked in to source control as they contain pc specific information and have caused problems for me in the past when multiple people have been working on the same project.  If you added everything to RSC using Robohelp you should be fine, but it's possible someone could have added the files manually through RSC (I haven't used it myself, but I assume it has similar basic functionality to other source control applications).

           

          If they are, delete manually from source control and commit the deletion. (Check that there are no other files checked out, or in a 'pending' state while you're at it.) Then I would delete the CPD and make a backup zip of the project for each PC (stored in a safe place away from you working folder), just to make sure you have a copy of all files in case they haven't been checked in properly or have been removed from source control. After that, I would delete the project from each PC completely and do a fresh "Get Latest" to make sure everyone has the same project files, and open and close the project on each PC. Do this on one PC at a time and make sure noone is working on the project until you're all synced. Try some of your standard workflow and see if you're still getting the problem.

           

          While you've got the "delete cpd" setting turned on, you could also try manually deleting the cpd before opening the project every time, just to see if that makes a difference. This would just (hopefully) rule out a problem with the automatic setting.

          • 2. Re: Project keeps getting removed from RoboSource Control 3.1
            rasterdan Level 1

            None of these files are in source control.

            • 3. Re: Project keeps getting removed from RoboSource Control 3.1
              rasterdan Level 1

              Rebooting our computers results in having our project thrown out of version control every time.  If we don't reboot our computers it works fine.  Only a reboot of the computer kicks us out.

               

              We have another project that works just fine regardless of rebooting.