3 Replies Latest reply on Nov 16, 2017 12:33 AM by Little_Pale_Face

    Elements Organizer 2018

    PDLumpy

      I recently added files to the Organizer so I wanted to backup my catalog. I go through all the steps , but when I press the make backup button the program says "Please wait while Elements Organizer prepares for Backup". Then I have waited for over an hour and nothing happens. If I do anything on the screen I get a "Program is not responding message" and the screen fades and a message says do I want wait for program or do I want to close the program. I have tried several times anfd same thing happens. Any help would be great. Thanks

        • 1. Re: Elements Organizer 2018
          Little_Pale_Face Most Valuable Participant

          Hi,

           

          Are you running on Windows 10?

           

          You could try doing a repair on your catalog to see if there are any errors there

          - Load organizer

          - Go to File -> Manage Catalogs

          - You should see your catalog marked as (current) - select it and click on the Repair button

          - If it finds any errors it should give you the option to repair them

          - Close the dialogue box

           

          You could make sure that there are no disconnected images - this is normally done by the backup but it might be worth doing first.

          - Load the organizer

          - Go to File -> Reconnect -> All missing files

          - If there are any missing files, you have option to reconnect them or remove them from the catalog.

           

          Now try the backup again

           

          How large is your catalog in terms of number of items?

           

          Brian

           

          • 2. Re: Elements Organizer 2018
            PDLumpy Level 1

            Yes I am running Windows 10 home 64 bit. There about 55,000 files in my catalog. I tried those things you said, but any thing I try ends up the same. When I tried each of those the program froze up. I don't what to do I cannot back up my catalog no matter what I try. Any help from anyone would be great. Thanks.

            • 3. Re: Elements Organizer 2018
              Little_Pale_Face Most Valuable Participant

              Hi,

               

              We need to establish whether the problem lies in the catalog or the system.

               

              To test that the organizer is OK, I would try creating a new test catalog

              1. Load the organizer

              2. Go to File -> Manage Catalogs

              3. Click on New, enter a name (like Test) and then click on OK

               

              That will create a new catalog, skip the import at this point as it will try searching all your files. Import a few images and test to see if the backup now works.

               

              Have you ever managed to backup under PSE 2018 or was your last backup under a different version?

               

              Are you backing up to an external drive or DVD?

               

              Which version of Windows 10 are you using? [Go to Start -> Settings -> System -> About and scroll down to Windows Specification you should see Version 1703 or 1709]

               

              Brian