4 Replies Latest reply on Nov 20, 2017 1:08 PM by mark@headTrix

    Question from a Newbie

    anthonyp10751017

      I created an AS3 animation.  I then created a layer as a movie clip symbol. I then created layers inside the main layer as graphics and animated a rain cloud, rain, lightning with masks etc.  When I preview with ctrl + Enter it previews perfectly how I want it. However in my main timeline the only thing visible is the first movie clip layer I created and it is showing as 1 frame.  If I click play on the timeline nothing happens.  How do I get the animation into the main timeline to play/export?  I tried copying all of the graphic layers inside my 1st layer and pasting them into the main timeline but then everything is out of place.

       

      EDIT: I should have mentioned this is all under "scene 1"

        • 1. Re: Question from a Newbie
          Lars Laborious Level 2

          Hi.

           

          It's a bit hard to visualize what you are doing here, but I think I get it.

           

          When you preview with Ctrl + Enter you see all the seperate movieclip's timelines play. While if you click play on the timeline from within Animate, you only see the timeline of the movieclip you're currently in.

           

          If you want to play out all animations from within Animate you should copy (as you mentioned you tried) them all into one main timeline, on seperate layers (just mark a layer, right click on it and choose Copy layers).

          1 person found this helpful
          • 2. Re: Question from a Newbie
            anthonyp10751017 Level 1

            See when I try that everything is thrown off...
            for example this is my main timeline (note its set as graphic in this screen shot bc I was trying to figure this out, but its usually a MC)

            https://i.imgur.com/l1lfHFq.png

             

            And if I go to my symbols and copy one and past it in the main timeline its completely offset

            Example: https://i.imgur.com/nu5Nnba.png

             

            When I paste all of them and play it, nothing is lined up right with the stage.

            • 3. Re: Question from a Newbie
              Lars Laborious Level 2

              I would guess this happens because the anchor point of your movieclips are not aligned with your main stage.

               

              Unless a movieclip is placed on the top left corner (x and y coordinate would be 0), it's internal coordinates will differ from the main stage.

               

              There are a couple of things you can do to line up everything right:

              Turn on Edit Multiple Frames and select the frames you want to move (probably the entire layer), then just drag them in place (make sure the Snap to Object magnet is activated). Or - still in Edit Multiple Frames mode - you can move the layer by changing the x and y in the properties panel (use the coordinates of the movieclip from which you copied the layer you want to move).

              1 person found this helpful
              • 4. Re: Question from a Newbie
                mark@headTrix Adobe Community Professional

                hi

                 

                so there are two things happening here ....

                 

                1. Movieclips are independent timelines that repeat no matter what is happening on any other timeline. So this means if you have a stop action on the main frame (which you sort of do since its ONLY 1 frame) it would still LOOP the MovieClip (MC). And MC's do NOT play in the main timeline... you have to Test Movie to see them moving. And when you test movie in essence you are exporting your file (check the folder where the main file is saved -- you should see it there) or you can go to File>Publish Settings and publish (export) your file to a SWF or OAM file.. or even File>Export>Export Movie to export to video.

                 

                Or you can try changing the symbols's BEHAVIOR to a graphic symbol (Like you did) ... but if you click on the symbol on the stage you will see properties where a graphic symbol can be 1. looped, 2. play once or 3. single frame. Graphic symbols mimic the main timeline... if you show 3 frames of graphic symbol you will see 3 frames of the animation (assuming its on play once or Loop)

                 

                2. when you tried copying and pasting like you did... not sure if you copied frames or just copied the symbols... you can try Paste in place... but it could be due to different x,y coordinates which in that case you would just use "Edit Multiple Frames" and move them all into position

                 

                Hope that helps!

                mark