2 Replies Latest reply on Dec 29, 2017 1:13 AM by my36506252

    Error Building iOS version in phonegap related to cordova-plugin-file-transfer

    hudville

      I keep getting this error in PhoneGap build for an app I have built successfully before:

       

       

      Installing "cordova-plugin-file-transfer" at "1.6.3" for ios

      Failed to install 'cordova-plugin-file-transfer': Error

        at /.nvm/versions/node/v8.1.4/lib/node_modules/pgb-plugman/node_modules/pgb-cordova-lib/src/ plugman/install.js:581:33

        at _fulfilled (/.nvm/versions/node/v8.1.4/lib/node_modules/pgb-plugman/node_modules/q/q.js:787:54)

        at self.promiseDispatch.done (/.nvm/versions/node/v8.1.4/lib/node_modules/pgb-plugman/node_modules/q/q.js:816:30)

        at Promise.promise.promiseDispatch (/.nvm/versions/node/v8.1.4/lib/node_modules/pgb-plugman/node_modules/q/q.js:749:13)

        at /.nvm/versions/node/v8.1.4/lib/node_modules/pgb-plugman/node_modules/q/q.js:509:49

        at flush (/.nvm/versions/node/v8.1.4/lib/node_modules/pgb-plugman/node_modules/q/q.js:108:17)

        at _combinedTickCallback (internal/process/next_tick.js:95:7)

        at process._tickCallback (internal/process/next_tick.js:161:9)

      Version of installed plugin: "cordova-plugin-file@5.0.0" does not satisfy dependency plugin requirement "cordova-plugin-file@^4.0.0". Try --force to use installed plugin as dependency.


      The version of the plugin I am installing in the config.xml is <gap:plugin name="cordova-plugin-file-transfer" source="npm" spec="~1.5.1" />

       

      Anyone familiar with this problem?