8 Replies Latest reply on Apr 23, 2018 10:49 PM by Maior ADV

    Move Tool delay with wacom in latest CC update - Help!

    justletmelookattheforums Level 1

      In past updates, disabling Windows Ink in Wacom settings let you have a fully-functional tablet with no lag and it was great. Now with the latest CC update, we're forced to use Windows Ink to get pressure sensitivity, but it comes with a TON of lag.

       

      I have disabled all "flicks," all "pen" settings, and the "press and hold" right click function in Windows Pen and Touch, as explained here. This removed brush lag (YAY) but I'm still getting a delay with the move tool when using the tablet pen.

       

      move_tool_delay.gif

       

      This is effectively the same problem outlined here. Photoshop doesn't react to input until you've moved the stylus maybe 1/4 of an inch--about 19 pixels at 100% zoom, which is absolutely infuriating when you're trying to make a small adjustment. It won't move at all and then it snaps suddenly to the location of the cursor.

       

      I need to make a lot of very small and precise movements like this very frequently and this is really causing me a lot of frustration!

       

      Again:

      ✔ All Windows Ink pen settings disabled.

      ✔ All Windows Ink flicks disabled.

      ✔ Windows Ink "press and hold" right click disabled.

      NOT experiencing input lag with brush.

      NOT experiencing movement lag with mouse.

      NOT experiencing movement lag with Windows Ink disabled (also disables pen pressure).

      ❌ Move tool delay present in Photoshop CC 2018 AND Photoshop CS6 with latest update.

       

      I'm on Win10 using an Intuos Pro tablet. Thanks for any help you can offer.

        • 1. Re: Move Tool delay with wacom in latest CC update - Help!
          justletmelookattheforums Level 1

          Hi friends, I'm bumping this to say that I'm still having this issue. I had to do a whole bunch of little fiddly perspective transforms today and this prevented me from making ANY kind of small adjustments--I literally have to try and memorize where the point was AND where I need it to be, because the clicked point is going to not move at all until it zooms a mile past where I need it and I'll have to drag it back and hope I put it back in the right location because if my memorization earlier was even a little bit off, now I have to do the whole process over again. It's turned "art" into "guess and check" and it's awful.

           

          This is making work take like three times longer than it needs to, PLEASE fix this!

          • 2. Re: Move Tool delay with wacom in latest CC update - Help!
            Paula Shin Level 1

            Yea... actually I have the same problem... Just moved from CC 2015 to CC 2018 and there are so many small glitches that infuriate me. CC 2015 had nothing of sort and I was hesitant to upgrade cause I was not in the mood to deal with it.

            But now the new stuff on CC 2018 are just too good to ignore...

             

            Now, is it maybe some plugin that might be interfering?

            I'm using a Cintiq Pro 16 here with Coolorus, Fontea and AD Brutus Symm.

            • 3. Re: Move Tool delay with wacom in latest CC update - Help!
              Paula Shin Level 1

              if feels as if all "moving commands" are dragging somehow...
              even when I move elements with the keyboard arrows, they don't seem as responsive compared to CC 2015 :/

               

              my computer is not the problem, I have a beast of a i7 with a GTX 1080. So this is really either a Photoshop bug, or a wacom bug...
              Judging by the fact that CC2015 was working nicely, then its a photoshop issue :/   

              • 4. Re: Move Tool delay with wacom in latest CC update - Help!
                justletmelookattheforums Level 1

                I'm not using any plugins besides SuperPNG, but the bug is still present on a clean install. I had to completely reformat the computer earlier (unrelated) and even after all that it's still happening.

                 

                I also have a really great computer and don't believe it's caused by performance issues, I agree! And yeah, I've noticed it on move tool as well as transform tool. It's not file size either; I showed some coworkers this morning on a brand new empty doc.

                 

                Thanks very much for the input. If nothing else, it's nice to know other people are having the same problem!

                • 5. Re: Move Tool delay with wacom in latest CC update - Help!
                  Paula Shin Level 1

                  I see... Thanks for informing about the problem persisting even after a formatted computer. I considered it to clear bugs and start fresh.

                   

                  Another thing I noticed... If I'm dragging groups of many elements, the "heaviness" of the drag seems even worse. Today I was moving a mockup group, with many elements, smart objects  etc. And it was worst than ever. It really felt as if photoshop was not handling it well.

                  In Photoshop CC 2015 I was using with the Windows Ink enabled and didn't have this sort of issue...

                   

                   

                  I believe other people must have this problem, they might just not be aware it is an issue. They deal as if its a "normal lag" thanks to a heavier version of the program :/

                   

                  Welp, lemme know if you find something

                  • 6. Re: Move Tool delay with wacom in latest CC update - Help!
                    Paula Shin Level 1

                    THIS: Photoshop CC 2018 IGNORES TABLET PROPERTIES  and Windows Ink Enabled = Delayed Reactions and Reverted Numbers

                     

                    Basically, in both posts the MVP JJMack explained how to disable the Windows Ink function WITHOUT loosing the pen sensitivity.

                    It worked for me! All the lag and "heaviness" I said before is just finally gone!

                     

                    Copy and paste from the other post, the full process of the fix is:

                     

                    1. Create a file that contains instructions to revert to the WinTab functionality.

                    2. Create a text file in a text editor such as Notepad.

                     

                    Type in the following lines:

                    # Use WinTab

                    UseSystemStylus 0

                     

                    3. Save the file as a plain text file named PSUserConfig.txt

                    4. Put (copy) the file into the Photoshop settings folder: C:\Users\[User Name]\AppData\Roaming\Adobe\Adobe Photoshop CC 2015\Adobe Photoshop CC 2015 Settings\

                    5. Restart Photoshop and check the pen pressure and overall performance.

                     

                    Now, just switch the "CC 2015" in the comment for the CC2018 folder and there we go!

                    I was able to turn off windows ink without loosing pressure-sensitivity..

                     

                    I really hope this helps you!

                    1 person found this helpful
                    • 7. Re: Move Tool delay with wacom in latest CC update - Help!
                      justletmelookattheforums Level 1

                      This worked for me!! I didn't switch it to CC2015, but putting the txt file into the settings folder and disabling Windows Ink resolved the transform/move tool lag and retains pen pressure. A coworker was having some severe lag so I'm going to throw this at them tomorrow and see if that helps there too. Thank you so much!

                      • 8. Re: Move Tool delay with wacom in latest CC update - Help!
                        Maior ADV

                        Hello to all.

                         

                        with this fix I solved the problem I had with photoshop!

                         

                        now I have the same problem with Lightroom. is there a way to do the same thing on Lightroom too?
                        I have a big lag with the brush tool (K)