0 Replies Latest reply on Nov 30, 2017 10:02 AM by peters78544578

    Phonegap App not working in iOS11

    peters78544578 Level 1

      I have an app that’s been on the Google and Apple stores for about 2 years now but it has stopped working with iOS 11. It fails to load properly, leaving some design-time text on the screen that should be replaced, and generates an error related to history.pushstate whenever a button is pressed. I’ve tried to upload a version onto a test device from a Mac but that simply reports that it couldn’t be installed (the test device is configured in my apple developer profile and even gets as far as showing the icon and the circular progress bar while it tries to install but then the icon goes black). Installing from the App Store appears to work but the splash screen fails to display (just the phonegap icon) and although the main screen loads it's entirely useless.


      On Android and earlier versions of iOS it worked and still works exactly as expected. The app is built using PhoneGap Build/CLI 6.50 so it should definitely be 64 bit.


      Not being able to even load it onto a test device rather restricts my options so I'm hoping someone might be able to suggest where to look? Is this a Phonegap issue or could it be a fault somewhere else? I'm using NSBasic to do the base development and Pushwoosh for push messaging.