0 Replies Latest reply on Dec 1, 2017 7:04 AM by kupkol

    Issue with publishing my windows app (phonegap) - invalid package identity name

    kupkol

      I have a problem with publishing my app in windows store. I recive these informations:

       

           Invalid package identity name: ... (expected: ...)

           Invalid package family name: ... (expected: ... )

           Invalid package publisher name: weird_numbers_instead_of_my_name (expected: ... )

       

      And I know that this problem was already known and I found an instruction what to do. The problem is that in my case it doesn't work any more. I found this piece of code:

       

          <author>Adobe</author>

          <name>PhoneGap Build App</name>

          <preference> name="windows-identity-name" value="PhonegapBuild.PhoneGapBuild" />

       

      in this post: https://forums.adobe.com/thread/2111557#

      I sticked to the instructions and it helped partly. Now I recieve this communiques:

       

           Invalid package family name: ... (expected: ...)

           Invalid package publisher name: weird_numbers_instead_of_my_name (expected:...)

       

      So I replaced my name in `<author>` with these 'expected' weird_numbers_instead_of_my_name. Then I recived a communique:

       

           Package acceptance validation error: The PublisherDisplayName element in the app manifest of (...).appx is weird_numbers_instead_of_my_name, which doesn't           match your publisher display name: my_name_that_i_gave_during_the_registration_process.

       

      So I changed again weird_numbers_instead_of_my_name to my real name which is of course the same as my_name_that_i_gave_during_the_registration_process. And then I recived again:

       

           Invalid package family name: ... (expected: ...) Invalid package

           publisher name: weird_numbers_instead_of_my_name (expected: ...)

       

      I specified cli of phonegap as well:

       

           <preference name="phonegap-version" value="cli-6.5.0" />

       

      So I'm wondering if this way given by ryanskihead does't work any more or windows store works in a different way than before. Any ideas?