3 Replies Latest reply on Dec 4, 2017 10:49 PM by joshua_d_boyd

    Getting Started with Plugins for Illustrator CC 2018

    joshua_d_boyd Level 1

      I am trying to do some maintenance work on a plugin that used to work with Illustrator CC 2017.

       

      First I tried updating the SDK to 2018 and otherwise building that as it was, but it gave me an Error loading plugins error.

       

      Second, I tried building some sample plugins and got the same results.

       

      Third, I tried following the guide for creating a new plugin following the guide in getting-started-guide.pdf in the 2018 SDK download, and again got the same results. I assume that if I can fix this, then I can work backwards threw the other examples and then the maintenance I originally wanted to do.

      Here is the what I created: TestPluginFirst.zip - Google Drive

      While following that guide, I did adjust the length of the name in the resource from 12L to 16L since I was using TestPluginFirst instead of HelloWorld (as well as adjust the padding from two padding chars to one).  I also had to adjust the include paths in "Configure the project settings" step 5, to add an extra "..\" in front of each of them. Same for the module definition file path in step 13. Additionally, I adjusted the output path in step 11 to match where the project files for the examples output their aip files.  I used the value "..\..\output\win\Win32\Debug\TestPluginFirst.aip" Finally, in "Debugging a plug-in under Visual Studio", step 3 I used the path "

      C:\Program Files\Adobe\Adobe Illustrator CC 2018\Support Files\Contents\Windows\Illustrator.exe" for my illustrator executable instead of the value shown in that PDF.

       

      The new plugin builds without errors.  However, when Illustrator starts it still says:

      Error loading plugins.

      TestPluginFirst.aip

       

      Looking at the output window in Visual Studio, I see the lines:

      Illustrator.exe' (Win32): Loaded 'C:\Users\jdboyd\Kimbo\AI_CC_2018_SDK_Win\Adobe Illustrator CC 2018 SDK\samplecode\output\win\Win32\Debug\TestPluginFirst.aip'. Symbols loaded.

      'Illustrator.exe' (Win32): Unloaded 'C:\Users\jdboyd\Kimbo\AI_CC_2018_SDK_Win\Adobe Illustrator CC 2018 SDK\samplecode\output\win\Win32\Debug\TestPluginFirst.aip'

       

      I don't see anything else that looks relevent.  And of course, the plugin is not shown in the plugin list shown in Help -> System Info.

       

      As to versions, I am using Illustrator CC 2018 22.0.1 (64bit).

       

      I am using Visual Studio Community 2015 Update 3, and I am using Windows 10. 

       

      Thank you in advance for any assistance offered.