1 Reply Latest reply on Dec 8, 2017 11:35 AM by jeromiec83223024

    Can't connect to any website for which Flash Player settings open and request permission

    rel555 Level 1

      (In advance, please excuse me when I make mistakes with terminology; I'm totally new to this.)

      Using Windows10 Home Version 1709.

      Windows64-bit,English, I've tried with the same results using Chrome, Internet Explorer, Edge, Firefox browsers

      Adobe Flash Player version 27.0.0.187

      Well,  for the past couple of weeks I haven't been able to broadcast or even establish a connection with websites after the Flash Player Settings open requesting permission for the website to access my camera and microphone.

      This is the instructions from one of the websites I'm having trouble with.  Nothing is clickable except "Next Step".

      When I click "Next Step", I'm carried through a couple more instruction pages then

      Now, you can see it's the same in different browsers.  When I click "allow" the dialogue immediately closes but doesn't actually let me adjust any settings, and I just get a "Can't connect to the website" message

      In Chrome it looks like this and there's a speed test

      in the above pic you can see a link to a speed test - if I click I get:

      In Firefox

      Each browser is just a little bit different, but basically the results are the same - I can't get a connection to the site with the Flash

      I have meticulously gone through the settings in each browser and enabled Flash Player.

      I have a really fast internet and i even plugged in the ethernet cable just in case of any problems with my wifi.

      Also tried a few other websites that broadcast live and it is the same thing...

      I used to be able to connect and interact with these sites, never had this problem before, the only thing that changed is that I did reinstall Windows 10 according to the direction of Microsoft support reps. I have chatted with Microsoft support for HOURS and those guys have no answers.  (They finally recommended asking Adobe Support.)  I've also chatted and emailed back and forth with the support teams from the individual websites.  All the troubleshooting and still no results.  Can you help?  I'm totally stuck.  Thank you. 

      Oh yeah, if I right click on the gray screen I get this Chinese stuff - (yes this time it's IE)

        • 1. Re: Can't connect to any website for which Flash Player settings open and request permission
          jeromiec83223024 Adobe Employee

          It's possible that you have the system region set to China or somewhere adjacent, but the language is still set to english.  We do take some cues from the region for legacy reasons, but a those are custom items in the context menu --- ours appear below the horizontal line, and they're in English as well.  In short, the content developer is supplying those entries, and they may similarly customize their string choices based on locale or region data supplied by Flash Player to ActionScript.  They're the best authority in terms of how their internal logic works.

           

          Anyway, the RTMP connection issues sounds like a firewall thing, and it may not be within your control.  You're able to connect to the website via HTTPS over port 443, but the RTMP connection (which is generally 1935, but can be arbitrarily defined) isn't getting to the remote server, and it isn't falling back to tunneling over port 443.  This could happen for a number of reasons, but most likely, some kind of service outage at the content provider that will probably resolve on it's own when they discover and fix it, a firewall configuration that blocks this at your computer or the network perimeter (more likely), or an issue in between you and the remote host that causes the traffic to get lost.

           

          There's no way for me to tell you why this is failing from here, but I'm pretty confident that RTMP is working for the vast majority of the population, simply based on the fact that there aren't hundreds of complaints streaming in (and we haven't shipped an update for a while).