1 Reply Latest reply on May 12, 2008 8:22 AM by Dragos GEORGITA

    unable to init TinyMCE in Adobe Air 1.0.1

    ICY_WOLFY
      Hi guys, was wondering how to init TinyMCE in Adobe Air 1.0.1

      basically i've coded a sample of TinyMCE 3.06 in a html file. is a fully client script running perfectly in IE and firefox however, after i compile under adobe runtime adl, it fails to init at all.

      any ideas how to work around? i've tried the bee sample it i think is written in the older runtime, couldnt get it to work even if i redo the application.xml...

      Sample of Source file

        • 1. Re: unable to init TinyMCE in Adobe Air 1.0.1
          Dragos GEORGITA Adobe Employee
          Hi,

          Bee sample uses an older version of the TinyMCE editor (I think it's 2.1.2) but the sample is running on the latest AIR runtime (1.0.1) - here is the link to it: http://www.adobe.com/devnet/air/ajax/samples.html

          However, due to security restrictions in the root content (in what we call the application sandbox) TinyMCE can run in non application sandbox but still be used from the root content. That's how it was implemented in Bee and it basically should also work with the latest version you have (3.06).
          Please check it out and I'll try to help you if you run into issues.

          Best regards,
          Dragos