9 Replies Latest reply on Dec 14, 2017 11:52 PM by MC Stuff

    Allowing anonymous access is not working

    Jdruwe Level 1

      In the 'apache sling authentication service' configuration bundle one can specify pages under authentication requirements. You can allow anonymous access of pages here as the dialog states:

      Defines URL space subtrees which require or don't require authentication. For any request the best matching path configured applies and defines whether authentication is actually required for the request or not. Each entry in this list can be an absolute path (such as /content) or and absolute URI (such as http://thehost/content). Optionally each entry may be prefixed by a plus or minus sign indicating that authentication is required (plus) or not required (minus). Example entries are "/content" or "+/content" to require authentication at and below "/content" and "-/system/sling/login" to not require authentication at and below "/system/sling/login". By default this list is empty. This list is extended at run time with additional entries: One entry is added for the "Allow Anonymous Access" configuration. Other entries are added for any services setting the "sling.auth.requirements" service registration property. (sling.auth.requirements)

       

      I am trying to share asset links to external entities as stated here (Asset link sharing ):

      Screen Shot 2017-12-06 at 12.21.49.png

      Here is my 'apache sling authentication service' configuration

      Screen Shot 2017-12-06 at 12.24.38.png

      As you can see I provided 2 absolute url's (not sure if the .html extension is required or not) but this is not working, is still get redirected to the login page. Am I doing something wrong?