25 Replies Latest reply on Dec 13, 2017 3:46 AM by venkateshg72779630

    Android compilation fails with facebook plugin

    Phendrax Level 1

      Hello,

       

      Since this morning I am not able to use Phonegap Build to compile my application.

      (It worked last week)

       

      This is what logs tell me:

      * What went wrong:
      A problem occurred configuring root project 'project'.
      > Could not resolve all dependencies for configuration ':_debugApkCopy'.
        > Could not find com.android.support:support-v4:27.0.1.
        Required by:
        project :
        > Could not find com.android.support:support-annotations:27.0.1.
        Required by:
        project : > com.facebook.android:facebook-android-sdk:4.29.0 > com.facebook.android:facebook-core:4.29.0
        > Could not find com.android.support:support-core-utils:27.0.1.
        Required by:
        project : > com.facebook.android:facebook-android-sdk:4.29.0 > com.facebook.android:facebook-core:4.29.0
        > Could not find com.android.support:appcompat-v7:27.0.1.
        Required by:
        project : > com.facebook.android:facebook-android-sdk:4.29.0 > com.facebook.android:facebook-common:4.29.0
        > Could not find com.android.support:cardview-v7:27.0.1.
        Required by:
        project : > com.facebook.android:facebook-android-sdk:4.29.0 > com.facebook.android:facebook-common:4.29.0
        > Could not find com.android.support:customtabs:27.0.1.
        Required by:
        project : > com.facebook.android:facebook-android-sdk:4.29.0 > com.facebook.android:facebook-common:4.29.0
        > Could not find com.android.support:support-v4:27.0.1.
        Required by:
        project : > com.facebook.android:facebook-android-sdk:4.29.0 > com.facebook.android:facebook-common:4.29.0
        > Could not find com.android.support:support-v4:27.0.1.
        Required by:
        project : > com.google.android.gms:play-services-auth:11.0.4 > com.google.android.gms:play-services-basement:11.0.4
      

       

      How can I fix it?

      Thank you