12 Replies Latest reply on Feb 17, 2018 2:19 AM by Ann Bens

    Need to install previous version - missing from list (screenshot)

    carl nes

      Hi

       

      I need to install a previous version of Adobe Premiere (Premiere CC 2015.2) and I have read online documentation on how to do this (and this article), but the strange thing is that the CC app does not list the previous CC 20xx versions prior to 2017. Reading online documentation this is strange, because CC 2016, 2015 etc should be listed here - See screenshots below:

       

      Any help appreciated:)

       

      I'm on Mac OS 10.12.6 (Sierra) and Creative Cloud app version 4.3.0.256

       

      This is how it looks for me when I choose to install previous versions:

       

      Skjermbilde 2017-12-07 17.29.04.png

       

       

       

       

      ... and this is how it looks like in adobe online documentation (and that I really need aswell)

       

      Skjermbilde 2017-12-07 17.28.37.png