7 Replies Latest reply on Dec 15, 2017 1:18 AM by Karin_Albrecht

    Bad performance when creating/moving folders/files in RH

    Karin_Albrecht Level 1

      Hi all,

      in the last weeks, I've been having very bad performance when I needed to create a new folder or file in one of my projects or when I tried to move this empty folder to the right place. The project manager tab becomes blank and it takes several seconds before the folder is created. This happens after creating, moving, renaming. Sometimes, RH even crashes and after restart, the new files are not in the project manager (however, when I recreate them, RH says, they already exist). Is anyone else having such issues? I browsed the forums and only found posts from 8 years ago. Any ideas what I could try to improve the performance?

      The size of my projects is about 200 files in 150 folders.

      CPU usage of RH is about 25 % while I'm waiting for the folder to be created.

      I'm using RH 2015 (12.0.4.460) with Windows 7. All available updates are installed.

       

      Thanks and kind regards
      Karin

        • 1. Re: Bad performance when creating/moving folders/files in RH
          Peter Grainge Adobe Community Professional (Moderator)

          Have you tried deleting the CPD file and reopening the project?

          • 2. Re: Bad performance when creating/moving folders/files in RH
            Karin_Albrecht Level 1

            Hi Peter,

            Thanks for your reply and your suggestion.

            I did delete the CPD file now. When I open my project after having deleted the cpd file, I get an error message: "when reading data from <c:\...\rhsharedresource.apj> <5> an error occurred". After clicking "Ok" (which is the only option I get), the links of my shared documents from different projects are no longer there (instead, the topic is actually created in my project and will no longer be synchronized). This rhsharedresource.apj is still in my project folder and seems not to have been changed since 27.11. according to timestamp. I have made a backup of my cpd and if I put it back into the project folder, the links will be there again.

             

            Performance stays really bad (like 20 seconds to create a new folder).

            Any further ideas?

            Best regards

            Karin

            • 3. Re: Bad performance when creating/moving folders/files in RH
              Peter Grainge Adobe Community Professional (Moderator)

              When RoboHelp recreates the cache (the CPD), it does so from various files including the APJ files. I think what has happened here is that it has found corruption in the rhsharedresource.apj.

               

              First let's make sure you backup the project as it is now before attempting anything else. Create a backup first. I always recommend creating the backup as a zip file. That prevents you opening it accidentally and working on it before you realise it was the backup. This way you always have a clean backup that can be used to create a new clean copy time after time.

               

              1] Grab a copy of the rhsharedresource.apj and open it in a text editor. Then do the same with the corrupt copy and look for differences in the structure.

               

              2] Try copying the backup into your project (you have the backup zipped if this goes wrong). Obviously it won't have any content added since the backup but it will be a better place than you are in.

               

              3] If that works, delete the CPD again and reopen. It should go past the rhsharedresource.apj and hopefully not find anything more. I think RoboHelp would have reported all the issues it found.

               

              4] If that works but the root problem still exists, I think I would then try deleting the XPJ file as well and using the HHP file to open the project. See Opening Corrupt RoboHelp Projects before you go down that path.

               

              Because you have that zipped backup you create first, if none of the above works, you have that to go back to.

               

              I did once encounter the same problem and I don't recall what I did. It was years ago so if you could post links to what you found, it might help.

               

              Let is know how you get on.

               


              See www.grainge.org for RoboHelp and Authoring information

               

               

              @petergrainge

              • 4. Re: Bad performance when creating/moving folders/files in RH
                Karin_Albrecht Level 1

                Thank you, Peter!

                I followed the first steps you supposed. There were no changes in the .apj file; copying the back up back into the project did not resolve the error when deleting the cpd-file.

                However, as I have the performance issue with all my projects, not just one, I have not yet tried the steps with deleting the xpj-file as well. RH also keeps crashing quite often when I try to move an open file to a new tab.

                I will investigate further and keep you up to date in case of any progress I make.

                Thanks for your help!

                Karin

                • 5. Re: Bad performance when creating/moving folders/files in RH
                  Peter Grainge Adobe Community Professional (Moderator)

                  Where are you projects located?

                   

                  If network, try a sample project as they are local.

                   

                  Then try a reinstall as it sounds like the whole thing is messed up.

                   

                  Have IT made any network changes such as auto backups?

                   

                  Peter Grainge

                  www.grainge.org

                  @petergrainge

                  • 6. Re: Bad performance when creating/moving folders/files in RH
                    Amebr Level 4

                    The other thing to check is changes to antivirus software. Many years ago we had dire performance with  a source controlled project, which was resolved by changing what the AV scanned. I forget the details, something like scan on save only, not on get? Hopefully that's enough for your IT guys to get the idea.

                    • 7. Re: Bad performance when creating/moving folders/files in RH
                      Karin_Albrecht Level 1

                      Hi,

                      Thank you both for your further ideas! After talking to IT, it actually seems to be an antivirus software issue. Hopefully, this will be resolved in the next couple of weeks.

                      However, what also improved the performance at least a little was that I emptied my automatically created TOC.

                      Thanks and kind regards

                      Karin