9 Replies Latest reply on Dec 19, 2017 2:57 PM by Rick Gerard

    Cannot Disable Adobe After Effects CC 2018 Auto Select Feature

    mrtermini

      Hi All,

       

      So I am hoping that this is just a really easy fix that I have somehow missed, but I cannot seem to get After Effects to stop auto-selecting when I click in the composition window. I have a layer (A) whose anchor point I am trying to move, but it currently overlaps another layer (B). The moment I try to click on layer A's anchor point with the Pan Behind tool to move it, After Effects instead selects Layer B. I had a similar problem with Photoshop CC 2018, but was able to turn off auto-select in the tool options. This does not seem to be an option with After Effects though, and I don't see any such option in preferences either. Can somebody tell me how to disable this incredibly annoying function? Thanks in advance!

        • 1. Re: Cannot Disable Adobe After Effects CC 2018 Auto Select Feature
          Gutterfish Adobe Community Professional

          mrtermini  wrote

           

          Hi All,

            I had a similar problem with Photoshop CC 2018, but was able to turn off auto-select in the tool options.

          Turning off auto-select in photoshop doesnt give you the ability to click on and select layers that are underneath other layers.

          It makes it so you cannot select layers in the canvas at all. Instead, you have to select your layers in the layer panel.

          So take that for what it;s worth.

           

          For After Effects, as far as I know there is no way to select a layer that is behind another layer in the comp panel unless the top layer is locked or the layer you want to select is solo'd.  Either way requires you clicking in the layer panel so it's just a s easy to select the layer you want to modify.

           

          So basically if you have layers you do not want to be able to select you have to lock it in the layer panel.

          An "auto-select" feature that functions in the way you describe does not exist in After Effects or Photoshop.

          • 2. Re: Cannot Disable Adobe After Effects CC 2018 Auto Select Feature
            mrtermini Level 1

            Hi, thanks for the response, but I think you misunderstand. Right now, if I click in the composition window to try and move an object or click-drag an anchor point, and another object is overlapping the one I am trying to work with, After Effects will instead select this new overlapping object. This is not something that I had ever encountered before with After Effects until just now, after I upgraded to AE CC 2018. Previously, in order to manipulate a different object, I had to select it in the timeline first, as you describe.

             

            In short, I only want to be able to select an object through the timeline, not by clicking on it in the main composition window. As is, AE is almost completely unworkable, especially given the number of objects in my scene.

            • 3. Re: Cannot Disable Adobe After Effects CC 2018 Auto Select Feature
              Gutterfish Adobe Community Professional

              Sorry for misunderstanding.

              So you are selecting the layer in the timeline, but then when you go to move the object in the composition panel it

              selects the "overlapping" layer.

              This is because you are not selecting directly on the anchor point.

              You're trying to select somewhere or anywhere in the objects bounding box.

              But there is another objects bounding box on top so it selects that.

              I don't know of any way to disable that behavior.

              you just have to  select the layer in the timeline and then grab directly on the anchor point.

               

              From your description it sounds like After Effects is behaving normally.

              • 4. Re: Cannot Disable Adobe After Effects CC 2018 Auto Select Feature
                mrtermini Level 1

                That's what I thought too, but even when I zoom in and click exactly in the center of the anchor point, my selection still changes. It's very frustrating.

                • 5. Re: Cannot Disable Adobe After Effects CC 2018 Auto Select Feature
                  mrtermini Level 1

                  With a little more experimenting, I have found the problem is not with single objects, but with nested pre-comps where the anchor point is in the center of the composition and not within the bounding box of the desired object. Trying to click on this anchor point causes my object to become deselected if there is nothing else there or selects the object which the anchor point overlaps.

                  • 6. Re: Cannot Disable Adobe After Effects CC 2018 Auto Select Feature
                    Gutterfish Adobe Community Professional

                    Hmmm.   I just tested it & I don't have that problem in 2018.  Maybe you could use some screen capture software  to record a quick video of what your doing.

                    • 8. Re: Cannot Disable Adobe After Effects CC 2018 Auto Select Feature
                      Gutterfish Adobe Community Professional

                      Thanks for that,

                       

                      This is not a bug I've heard of before.  Maybe you've discovered it.

                      I guess all you can do is file a bug report and go back to using 2017 

                      1 person found this helpful
                      • 9. Re: Cannot Disable Adobe After Effects CC 2018 Auto Select Feature
                        Rick Gerard Adobe Community Professional & MVP

                        I cannot reproduce your problem. The screen capture is very hard to follow because there is no explanation of what you are showing us but it looks like a layer that is a pre-comp always has the same anchor point and if you try and select that anchor point then the layer is deselected. I noticed that selecting the anchor point on the girl seemed to work and it looked like the nested comp of the girl has been cropped to just include the artwork. The anchor point for the girl seems to make sense. Ther anchor point for the boy layer does not make sense because it is outside the layer boundary. I'm not sure how this happened unless you moved it manually. I would press the 'u' key twice to reveal all modified properties of all layers and explore the anchor point position for each layer and make sure that each nested comp is not one where you selected some artwork and then forgot to move all attributes to the new composition. Getting a pre-comp to crop to the selected artwork is a bit of a trick that most folks don't follow.

                         

                        If your version of AE is up to date and you have gone through all the preferences and checked everything then I suspect this may be a combination of workflow, GPU, and OS problem. No matter what I do I cannot get my CC2018 on OSX 10.13.1 to behave badly.