6 Replies Latest reply on Dec 18, 2017 3:22 PM by derekn38784682

    Issue with Stamp Tool

    derekn38784682 Level 1

      I have an odd issue with the stamp tool.  I have some photos where a flash generated a background shadow.  I sucessfully removed the shadow from one of the photos, but the other is being stubborn.  The stamp tool seems to be sporatically working.  I will be flowing fine, then without reason it will not stamp certain areas of the the photo.  I have attached a sample of what it looks like.   The yellow arrows point to the areas the stamp tool is refusing to stamp. Has anyone had this issue and what did you do to get around it?

       

      Thanks

      Stamp.JPG

        • 1. Re: Issue with Stamp Tool
          JJMack Most Valuable Participant

          Have you ever tried to clone into a new empty layer on top of the layer?

          Stamp.gif

          • 2. Re: Issue with Stamp Tool
            Trevor.Dennis Adobe Community Professional

            Make sure that the blend mode is set to Normal in the Options bar, and not something like Darken.

             

            Looking at your screen shot, I'd probably be using the Patch tool to fix the bits of shadow.

             

            There are two tricks when using the Patch tool. The first is when the artifact is close to an area you don't want to bleed into the area you want fixed. The trick here is to select both sides of the line, and move the selection _along_ the line.  This will leave the dark area (in this case) unchanged, and fix the shadow artifact in the lighter area:

            The second is when the problem is close to two or more areas that you don't want the patch tool to sample from (cyan highlight).  The fix is to select the areas that you do want to be sampled, and copy to a new layer.  Lock the transparency, (green highlight) and then use the Patch tool as you normally would.  It can now only use the pixels you supplied it to make the fix.

            1 person found this helpful
            • 3. Re: Issue with Stamp Tool
              derekn38784682 Level 1

              JJMack,

               

              Thank you for your response.  Regarding your initial question, I added a layer to the original, so are you asking if I tried adding a second layer?  If so, then no.  Is that what you did? I wasn't using a patch tool at all... just the clone stamp, so I will definitely give that a shot.  I'm really confused that the first photo which was almost identical to this one gave me no issues at all with the clone stamp. 

               

              Thanks!

              • 4. Re: Issue with Stamp Tool
                BarbBinder Adobe Community Professional

                The key to using the Clone tool, Derek, is to recognize that there are two cursors on screen once you begin painting. Our eyes are drawn to the area we are painting (the circle), but really you need to keep an eye on the crosshair cursor. If you roll over a shadow with the crosshair cursor, you are going to clone it. Release the mouse prior to the crosshair cursor touching the shadow and either take a new sampling point, or uncheck Aligned in the Options bar, which lets you start back at the original sampling point each time you release the mouse.

                 

                ~Barb

                1 person found this helpful
                • 5. Re: Issue with Stamp Tool
                  JJMack Most Valuable Participant

                  I added an empty layer on top of your image made a selection of the area I wanted to be able to clone into and used the clone stamp tool. No harm is done to your image layer that way.  This time I feathered the clone stamp tool so you can see where I dabbed.  Notice I sample a single spot and have aligned unchecked in the option bar. You can see the sample stamp brush over the right side of the image that is not in the image and can not be cloned into the layer for its outside the selection.

                  Capture.jpg]

                  Stamp.gif

                  1 person found this helpful
                  • 6. Re: Issue with Stamp Tool
                    derekn38784682 Level 1

                    Thanks MMJack... this got me over the hump.  It's still odd why its acting like it is.

                     

                    BarbBinder... thanks for the assists, but I was beyond knowing the general functionality of the clone stamp tool.  I simply had an anomaly that wasn't normal.  Glad someone else found your comments helpful though.