19 Replies Latest reply on Jan 16, 2018 6:22 PM by SugarTallerino

    Draggers not working

    SugarTallerino Level 1

      I want to start with recording her playing the guitar before I move on to recording the lip sync, but the draggers aren't working. Also, without the staple function, how do I attach the hands to the arms? QueenCAEp1Guitar.puppet - Google Drive

        • 1. Re: Draggers not working
          Kevin-Monahan Adobe Employee

          Hi SugarTallerino,

          Sorry for the frustration. This doc should assist you with the tools around dragging objects: Edit and modify puppet structure

           

          You can attach hands to arms automatically. This video shows how. Let us know if it assists you or not.

           

           

          Thanks,
          Kevin

          • 2. Re: Draggers not working
            SugarTallerino Level 1

            When she's holding a guitar, the arm and hand need to move independently of eachother.
            Also, I watch all the videos, and try to solve problems myself before I come here, so when you post the videos as the answer to my question you're not helping me ;(. And no one even addressed why the draggers did nothing this time for some reason.

            • 3. Re: Draggers not working
              DanTull Adobe Employee

              Hi, I haven't had a chance to fully confirm (by making all the required changes myself), but did take a look at your puppet and can hopefully help diagnose what is going wrong.

               

              I think the trouble is an issue with your arm structure. Take the right arm for example. It has 3 parts: Right arm (upper arm), Right Arm Low (forearm), and right hand. The hand and upper arm are both warp independent, but the lower arm (and the glove) are not. Also, the draggable handle closest to the hand is on Right Arm Low which (because it is not crowned warp independent) warps with the body which has a rather large mesh that is (for reasons I don't fully understand yet) using a somewhat rectangular mesh. I think that is probably due to having a number of loose (non contiguous) parts grouped under it.

               

              So, to start, I think what you'll need to do is get the right arm parts under one group and make that one group warp independent (with the crown) so that the whole arm warps together, but still separately from the body. The left arm needs slightly different treatment. The left arm part behind the guitar will need a dragger handle but to preserve the way the arm is behind the guitar but the hand is in front, the hand will need to be made into a warp independent group (so it can have its own dragger behavior and handle). That way, the left arm and the left hand will move together while still being behind and in front of the guitar.

               

              You may also run into some (performance) trouble with all the warp independent hair strands later, but I think there's a way to work through that as well.

               

              Hopefully this is a start at helping out! Let me know how it goes and I'll try to watch for further replies.

               

              DT

              1 person found this helpful
              • 4. Re: Draggers not working
                SugarTallerino Level 1

                OK I've been looking through all the forums to figure out why I'm having distortion issues now!! I fixed the .ai file to incorporate your suggestions, and before i could even get started now I have another problem! I've tried adjusting the settings, everything I can think of? QueenCAEp1Guitar2.puppet - Google Drive

                • 5. Re: Draggers not working
                  DanTull Adobe Employee

                  Sure, let me take a look. I noticed some weird warpy/floaty stuff when I looked last time, but figured I'd stick with the dragger stuff first.

                   

                  DT

                  • 6. Re: Draggers not working
                    DanTull Adobe Employee

                    The Eye Gaze behavior seems to be what is causing the warping based on turning toggling the eyeball on that behavior in the properties panel off and noting that most of the weird warping stops. It looks like a combination of some tagging and warp independence issues. Shouldn't take too long to track down. I also dis-armed the head turner so I can start with just the frontal face.

                     

                    DT

                    • 7. Re: Draggers not working
                      DanTull Adobe Employee

                      Found it. Most of the problem is that the 5 head groups (left/right profile/quarter and frontal) had some stray tags (left/right pupil and range). This was causing small eye movements to pull on the mesh for the whole head.

                       

                      You'll probably want/need to pick a new layer to be the pupil range to help the eye gaze pick a reasonable area in which to move, but removing the stray tags seems to fix the main issue I was seeing.

                       

                      I do still see some flicker when the head turns kick in. I'm not sure yet, but I think this may actually be a performance issue because of all the layers/groups in the face that are warp independent. I may look at that a bit more tomorrow.

                       

                      DT

                      1 person found this helpful
                      • 8. Re: Draggers not working
                        DanTull Adobe Employee

                        No, wait.I just found it. There's some stray cycle layers animations in a couple of the head turns. Most of them are not visible, but a few are, so they were causing a bunch of random face parts to play back each time that view was shown.

                         

                        DT

                        • 9. Re: Draggers not working
                          SugarTallerino Level 1

                          How can I get the cycle layers to work properly?

                          • 10. Re: Draggers not working
                            DanTull Adobe Employee

                            I just turned them off for now to avoid the flickering. Are these the start of animated head turns for smoother transitions? (like this video: Character Animator Tips & Tricks (January 2017) - YouTube)

                             

                            It looked like you had cycle layers set on a group that _contained_ the parts of a head, but that'll cause it to show each layer in the group in turn, so I think the problem is that you had cycle layers on the individual 1, 2, 3 and sub groups of the view, but I think it needs to go one level up so that 1, 2, and 3 are _frames_ in the cycle instead of individual cycles themselves.

                             

                            I'd say for now just turn off the eyeballs on those and circle back once the rest of the puppet is working well (the artwork looks really nice, by the way) since the smooth head turns is a bit more advanced technique that can be tricky to get right.

                             

                            DT

                            1 person found this helpful
                            • 11. Re: Draggers not working
                              SugarTallerino Level 1

                              sZjx5Zaz4JHOAem73 Yes thank you that sounds exactly right. yes I'm trying to make a smooth head turn!! Thank you so much for the hard work!I0d2g7IQMGRZmehw1

                              • 12. Re: Draggers not working
                                Kevin-Monahan Adobe Employee

                                Hi Hi SugarTallerino,

                                Did DanTull answer your question with his latest response? Please let us know.

                                 

                                Thanks,

                                Kevin

                                • 13. Re: Draggers not working
                                  SugarTallerino Level 1

                                  I'm still working on it!! Thanks so much for the quick response, I'll report back this evening

                                  • 14. Re: Draggers not working
                                    Kevin-Monahan Adobe Employee

                                    Cool, good luck!

                                    • 15. Re: Draggers not working
                                      SugarTallerino Level 1

                                      OK I believe I followed the instructions carefully, I know you put time into it and I appreciate it! The head is not distorting, I'm going to flatten the 'imbetweens' next for a smooth head-turn so that's going well! But I still can't get those draggers to make her play her guitar!! QueenCAEp1Guitar2.puppet - Google Drive

                                      • 16. Re: Draggers not working
                                        SugarTallerino Level 1

                                        I tried adding another dragger but it didn't work??

                                        • 17. Re: Draggers not working
                                          DanTull Adobe Employee

                                          I did some experimenting with this today. I did have to adjust a few things:
                                          - Added a draggable handle on the Right Hand group.
                                          - Disabled the crown on the Right Hand/Right Arm Low groups so the whole arm is one mesh

                                          - Moved the right arm handle up to the shoulder so it attaches there to the body (look for the body to turn green to indicate it is the auto attach target)

                                          - Added a stick for the upper and lower arms (so they warp in a way that seems more like how an arm would bend (may still require some fiddling to get the right look)

                                          - Moved the left arm handle to the left shoulder so it attaches to the body there
                                          - Added a draggable handle for the Left arm group to a place at the end of the arm (behind the hand).

                                          - Added a draggable handle to the Ghand group

                                          - Added a dragger behavior to the Ghand group

                                          - Set the attach style of the Ghand group to Free (so it doesn't pull on the body mesh)

                                           

                                          The motion probably still requires some tuning. Also, since the right arm is a different dragger from the left hand, they both move when moving the right arm. To avoid that, I disarmed the left hand's dragger behavior when moving the right arm.

                                           

                                          Both hands may also need a triggerable cycle layers animation to add some finger movement, but that's separate from getting the core dragger part working.

                                           

                                          Hopefully this helps,

                                          DT

                                          1 person found this helpful
                                          • 18. Re: Draggers not working
                                            SugarTallerino Level 1

                                            OK! I have some work to do, thank you SO much!

                                            • 19. Re: Draggers not working
                                              SugarTallerino Level 1

                                              I believe I did everything you said to do correctly, I was careful, and no matter what I do the arms just won't attach to the shoulders.QueenCAEp1Guitar2.puppet - Google Drive
                                              I'm exhausted trying to get this thing to work, I'm just going to do what I can with AE and PPro, CA is really very slow right now anyway. I'll keep trying as upgrades happen. Thanks!