9 Replies Latest reply on Jan 3, 2018 3:36 AM by Ged Traynor

    ARGGHHH PHOTOSHOP NOT WORKING

    rebeccab64510331

      For two days now i have tried to open photoshop, i have the free cloud app trial that is linked to my company  (a university) so I don't pay but can use the cloud trial all year) It wasn't working so i followed ll the instructions on how to fix it, none of which worked, i then did a complete deep clean uninstall and reinstall (done this three times now!) still nothing, updated my mac to latest operating stytem to see if that helped, nothing, restarted computer (lots of times now) nothing, installed bridge because heard that helped...nothing, obviously cleared and reinstalled complete adobe system including app manager - nothing - when i click on photoshop it bounces for a while, then a validation page comes up which flashes for less than a second, then get a creative clout page which says wait a moment and then a wheel for hours, obviously also deeply uninstalled and reinstalled the creative cloud also.... nothing! driving me mad, is there a phone number where i can ask for help or anyone got any suggestions that are not already in the 'how to fix the issue' pages because i have already followed them - been here for two days now :.(((