5 Replies Latest reply on Jan 9, 2018 7:30 AM by kglad

    "Error initializing Java Runtime Environment. You may need to reinstall flash."

    siddhants46248098 Level 1

      So I attempted the virtual camera tutorial animation on the adobe webpage for Animate CC.

      When the animation was complete, I tried to export it as a .mov file.

      However, I was greeted with the message: "Error initializing Java Runtime Environment. You may need to reinstall flash."

       

      So I tried uninstalling and reinstalling Flash Player for my default browser(Firefox), but nothing.

      I was told to delete and recreate/modify the jvm.ini file in my Configuration folder in the install directory, so I did. I changed -Xmx256m to -Xmx1024m to -Xmx128m and back to -Xmx256m; I deleted it and restarted Animate CC, I moved it from C:\Users\myUsername\Appdata\Local\Adobe\Animate CC 2017\en_US\Configuration\ActionScript 3.0 to my install directory\Common\Configuration\ActionScript (which did not already have it for some reason- is this normal?) and to the en_US\ConfigurationActionScript 3.0 folder in the install directory, then copied it around and put it in half of the folders in the install directory. Still nothing.

      I tried running the application as an administrator. This had no effect.

      Someone else advised me to install the 2010 and 2008 Microsoft C++ Redistributable Packages- this does not make sense to me as I already have the more recent 2012 packages, which I don't want to remove in fear of disrupting other applications I frequent that require them.

      This seems to be a problem caused by ActionScript ONLY, as there was no error message when I removed the Camera and tried exporting (hence I put it here and not in General.)

      Does anyone have a solution? This problem has been tearing at my sanity for 2 days now, I haven't been able to move on to other projects as I have a feeling all ActionScript documents will suffer the same fate, preventing me from using any camera, 3D or code at all. I would hate to have to move to other animation software because of this tiny error message. I can provide additional information too- any help would be greatly appreciated. Thanks in advance!