2 Replies Latest reply on Jan 13, 2018 3:13 AM by andersborglund

    Error : - Plugin error (you probably need to remove plugin files from your app)

    mueend15392321

      I want to use the facebook account kit plugin, so i am including this plugin

       

      cordova-plugin-facebook-account-kit

       

      I am getting this error when i am trying to build.. It says 'you probably need to remove plugin files from your app' but i have not included any of the plugin files inside the package.

       

      image

       

      Thanks!

        • 1. Re: Error : - Plugin error (you probably need to remove plugin files from your app)
          theRealDeviros Level 1

          Couple of things:

           

          1. sometimes the app directories can get weird - and there have been times where I've just created a brand new Cordova/PG project and copied all my important project files to the new project, because honestly, in many cases that's faster than trying to troubleshoot something that's super obscure.
          2. It's possible that there's an actual other plugin that's causing this issue, and not reporting it's name properly.  You can attempt to deactivate plugins one by one and see if it builds successfully, or deactivate EVERYTHING (non cordova core, ofc) except this one plugin and see if it works.
          3. I don't know much about this particular plugin, but it appears to be super beta- 0.1.6.  Try to see if there's a newer version you can tag, or, it could just be buggy, and you may need to find a different solution.
          • 2. Re: Error : - Plugin error (you probably need to remove plugin files from your app)
            andersborglund Level 2

            It says outright that an earlier plugin has changed attributes that also this plugin changes, so look in the list of plugins before this one.

             

            I imagine there are more stable/finalized plugins for accessing Facebook, but maybe you need something only this plugin has.