0 Replies Latest reply on Jul 6, 2008 12:27 AM by

    HTTPService + SimpleEmailForm - Problem with character

      Problem with swedish character å, ä och ö in a simple form mail with flex, php and mySQL.

      Have tried to change this in flex - mySimpleFormMail.mxml:
      <?xml version="1.0" encoding="utf-8"?> to
      <?xml version="1.0" encoding="Latin1"?> and to
      <?xml version="1.0" encoding="iso-8859-1"?>

      Have also at the same time changed this in mail.php:
      <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> to
      <meta http-equiv="Content-Type" content="text/html; charset=Latin1" /> and to
      <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />


      The mySimpleFormail looks like this is this:

      From---------------------------------------
      Name----------------------------------------
      To------------------------------------------
      E-mail---------------------------------------
      Mesage---------------------------------------

      SEND (button)


      The e-mail generated from mySimpleFormail looks like this:


      From: Patrik Hällman
      Email Address: patrik@myhomesite.se
      To:
      Patrik Hällman
      Email Address: info@myhomesite.se

      Message:Now I´m testing with the swedish character - åä och ö.



      ...as you can see swedish character å, ä och ö is wrong displayed.




      Here is the result from <traceTarget>:

      [SWF] C:\AppServ\www\email \bin-debug\email_send4.swf - 910 229 bytes after decompression
      'AB8F6784-15FC-7BD4-D26D-F73192A7717F' producer set destination to 'DefaultHTTP'.
      'direct_http_channel' channel endpoint set to http:
      'AB8F6784-15FC-7BD4-D26D-F73192A7717F' producer sending message 'AA84F829-98F0-E93F-D7AC-F732847CF6B2'
      'direct_http_channel' channel sending message:
      (mx.messaging.messages::HTTPRequestMessage)#0
      body = (Object)#1
      emailMessage = "Now I´m testing with the swedish character å, ä and ö."
      senderEmail = "patrik@myhomeiste.se"
      senderName = "Patrik Hällman"
      sendToEmail = "info@myhomesite.se"
      sendToName = "Patrik Hällman"
      clientId = (null)
      contentType = "application/x-www-form-urlencoded"
      destination = "DefaultHTTP"
      headers = (Object)#2
      httpHeaders = (Object)#3
      messageId = "AA84F829-98F0-E93F-D7AC-F732847CF6B2"
      method = "POST"
      recordHeaders = false
      timestamp = 0
      timeToLive = 0
      url = " http://www.myhomesite.se/email/email.php"
      'AB8F6784-15FC-7BD4-D26D-F73192A7717F' producer connected.
      'AB8F6784-15FC-7BD4-D26D-F73192A7717F' producer acknowledge of 'AA84F829-98F0-E93F-D7AC-F732847CF6B2'.
      Decoding HTTPService response
      Processing HTTPService response message:
      (mx.messaging.messages::AcknowledgeMessage)#0
      body = "<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" " http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
      <html xmlns=" http://www.w3.org/1999/xhtml">
      <head>
      <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
      <title>Untitled Document</title>
      </head>

      <body>
      </body>
      </html>
      "
      clientId = "DirectHTTPChannel0"
      correlationId = "AA84F829-98F0-E93F-D7AC-F732847CF6B2"
      destination = ""
      headers = (Object)#1
      messageId = "5624FC90-E89E-2B47-92B9-F7328A8CB993"
      timestamp = 0
      timeToLive = 0


      --------------------------------------------------------------------------------


      This is catastrophic when you working with cms and databases.

      All help I can get from this forum is really appreciated.