15 Replies Latest reply on Jan 14, 2018 8:52 AM by johnrellis

    Keyword Hierarchy Help

    Davegray1941 Level 1

      I'm new to Lightroom, and from what I've read, If I create a keyword hierarchy and assign a keyword to the lowest item the keyword should also be assigned to the higher levels. This is not what is happening. For example, I've created a hierarchy of PLACES>USA>Sacramento, and when I add  the Sacramento keyword to some images only the Sacramento keyword is assigned, and not the USA and PLACES keywords. Am I doing something wrong, or is this the correct behaviour?

        • 1. Re: Keyword Hierarchy Help
          dj_paige Level 10

          I'm new to Lightroom, and from what I've read, If I create a keyword hierarchy and assign a keyword to the lowest item the keyword should also be assigned to the higher levels.

           

          This is correct.

          This is not what is happening. For example, I've created a hierarchy of PLACES>USA>Sacramento, and when I add  the Sacramento keyword to some images only the Sacramento keyword is assigned, and not the USA and PLACES keywords.

           

          But this is happening. In the Keywording section of the Library Module, set the dropdown menu to Keywords and Containing Keywords.

          • 2. Re: Keyword Hierarchy Help
            Davegray1941 Level 1

            Thanks for your reply. I can now see the keywords in the Keywording section. However, no photos are showing against USA or PLACES in the Keyword list, and if I click on either of them, no photos are found that match the filter condition. So although the keywords are showing in the Keyword section, they don't seem to have been assigned to PLACES or USA.

            • 3. Re: Keyword Hierarchy Help
              dj_paige Level 10

              Exactly what are you clicking on? Show us a screen capture.

              • 4. Re: Keyword Hierarchy Help
                Davegray1941 Level 1

                lr.jpg

                 

                lr2.jpg

                I have added just one image for practice. As you can see in first screenshot, the Sacramento keyword has one image showing, but the PLACES and USA have none. When I click on the small arrow to the right of Sacramento, the image shows in the Library window. If I hold the cursor to the right  of PLACES or USA there is nothing there. So if I wanted to find images with the keyword of USA I would be unable to. Does this make sense?

                • 5. Re: Keyword Hierarchy Help
                  dj_paige Level 10

                  Ok, got it. The keyword USA will only show a number next to it if you have specifically and explicitly assigned a photo the USA keyword. Assigning the photo the keyword Sacramento will not cause the number next to USA to increase.

                   

                  If you want to see all photos with the USA keyword, you hold your mouse over the word USA, an arrow will appear at the right, and you click on that arrow.

                  • 6. Re: Keyword Hierarchy Help
                    Davegray1941 Level 1

                    lr3.jpg

                    This doesn't happen. When I hold the cursor over USA and then click on the arrow, no image appears and I see the above window.

                    • 7. Re: Keyword Hierarchy Help
                      dj_paige Level 10

                      So what is different here?

                       

                      At the top left, it shows a 0 next to USA, but for my keywords that have only child keywords assigned, no zero appears.

                       

                      Is it possible that you have not selected "All Photographs" on the left hand side of the Library Module? Could you please try clicking on "All Photographs" and then repeating the search.

                       

                      Other than that, I do not know why this would be happening with your Filter bar showing a 0 next to USA, and mine not showing any number at all. I'll have to think about this.

                      • 8. Re: Keyword Hierarchy Help
                        Davegray1941 Level 1

                        Yes, 'All Photographs' is selected. I have only recently started to learn LR, so I'm stumped as to what is happening.

                        • 9. Re: Keyword Hierarchy Help
                          johnrellis Most Valuable Participant

                          Your catalog's keyword list appears to be corrupted somehow.  The Library Filter bar shows a number of keywords that aren't appearing in the Keyword List panel: Tom Rush, Tony Carter, Uncle Joe, Vera.

                           

                          1. Please do Help > System Info and report the exact version of LR and Mac / Windows.

                           

                          2. Did the photos have keywords assigned by some other software program (e.g. Windows File Explorer) before you imported them into LR?

                           

                          3. Try resetting LR's preferences: https://www.lightroomqueen.com/articles-page/how-do-i-reset-lightrooms-preferences/ . That (unfortunately) often fixes things when LR's user interface goes wonky.

                          • 10. Re: Keyword Hierarchy Help
                            Davegray1941 Level 1

                            Thanks for your response. The reason the keywords you mentioned aren't appearing is that they are in the People list. The list I had selected for the example was the Other list. All of these keywords do appear in the People list.

                             

                            I have tried your suggestion and resetted the preferences but with the same result. The version is LR CC Classic 7.1.

                            • 11. Re: Keyword Hierarchy Help
                              johnrellis Most Valuable Participant

                              Mysterious.  Perhaps you could share the entire keyword list by doing Metadata > Export Keywords, opening the exported file in a text editor (e.g. Notepad or TextEdit), and copying and pasting the contents here.  That might give some clues.

                              • 12. Re: Keyword Hierarchy Help
                                Davegray1941 Level 1

                                Rather than waste any more time on this problem, I decided to  delete all of the keywords and start again. After deleting them I then created a hierarchy of PLACES > USA > California > Sacramento. I then assigned the Sacramento keyword to an image and lo and behold, it worked! If I now click on the arrow alongside any of the keywords in the hierarchy, the image is found. As you can see from the screenshot, there is not now a zero against the keyword in the Library Filter. This is is what I think dj_paige is seeing.

                                 

                                It seems that my original keyword file must have been corrupt.

                                 

                                Thank you both for your help and suggestions.

                                lr.jpg

                                • 13. Re: Keyword Hierarchy Help
                                  johnrellis Most Valuable Participant

                                  It seems that my original keyword file must have been corrupt.

                                  Yes indeed, which is disturbing.  After many years of stability, LR 7 has introduced several Library bugs in the catalog database.

                                   

                                  To help others troubleshoot in the future: Did any of your photos already have keywords attached when you imported them into LR, e.g. by using another program?  Did you do Metadata > Read Metadata From File at any point?  (That triggers one of the newly introduced bugs.)

                                  • 14. Re: Keyword Hierarchy Help
                                    Davegray1941 Level 1

                                    Before switching to Photoshop and then Lightroom, I had been using PS Elements for a number of years, and when I first opened LR and selected Import, I was asked if I wanted to import my Elements Catalog. Not knowing any reason why I shouldn't choose this option, I selected yes, so all of the keywords I had created in Elements were imported into LR, so this is quite possibly the reason for the problem? I am now going through all of my images and deleting the metadata which was added by Elements before importing into a new LR Catalog.

                                     

                                    I didn't do a Metadata>Read Metadata From File.

                                    • 15. Re: Keyword Hierarchy Help
                                      johnrellis Most Valuable Participant

                                      I was asked if I wanted to import my Elements Catalog. Not knowing any reason why I shouldn't choose this option, I selected yes, so all of the keywords I had created in Elements were imported into LR, so this is quite possibly the reason for the problem?

                                      Almost certainly. The conversion from PSE to LR has never been great, and there have been occasional problems reported with it over the years.  When I converted from PSE 8 to LR 3, the process was so glitchy that I ended up using my "psedbtools" utility (no longer supported) to work around numerous PSE metadata bugs and then my own LR plugin script to get my catalogs correctly converted.