4 Replies Latest reply on Jan 16, 2018 1:47 AM by davescm

    Layers gone!

    scotts31507836

      I am getting really frustrated. I have read several forums and there doesn't seem to be a clear answer on this issue. Recently, my photoshop has begun to not work properly. I do a lot of work where I need to make several edits to a file. I usually create a psd first then save as pdf, but occasionally I just save it as a pdf. Either way, when I save my file, and come back to edit, all layers have been merged. It only shows a background layer so I cannot edit the file. I make sure the layers box is checked and follow all the correct steps that I have been following forever. Now all the sudden it is flattening the image when saving.

       

      Can anyone help with this problem? I am losing too much work because of this.

        • 1. Re: Layers gone!
          ahmad al haj qasem Level 3

          Hi

          When you click 'save as' below where you put in your file name and type of file you want to save it as there is a bunch of tick boxes, so you just ticked the 'layers' tick box (which gave you a yellow attention notice in any case) ... and voila!!! Everything is back to normal

          so you need to check the layer option otherwise it will be one layer instead of the original layers 

          • 2. Re: Layers gone!
            scotts31507836 Level 1

            I do, as mentioned in my post, make sure it is ticked. That doesn't help.

            • 3. Re: Layers gone!
              cinziamarotta Adobe Community Professional

              Hi,

              it's possible the layered PSD image became corrupted and Photoshop is just loading the flattened composite.

              I suggest resetting Photoshop's preferences, just to rule out a corrupted preferences file.

              To reset the preferences:

              Press and hold Alt+Control+Shift (Windows) or Option+Command+Shift (Mac OS) as you start Photoshop

              • 4. Re: Layers gone!
                davescm Adobe Community Professional

                Hi Scott

                This is a common issue and is caused by the checkboxes.

                 

                1. When you first save a PSD , it will have save layers checked

                 

                2. When you save as a PDF there is a warning - but the implications are easily missed

                If you uncheck Preserve Photoshop Editing capabilities to widen compatibility then the PDF is saved flattened as you would expect, although the layers remain on your open document so you can still do a further Save As and save it unflattened if you wish

                 

                 

                 

                 

                 

                3. But there is a further "gotcha" (which is what the warning eluded to).  If you now try to Save As a PSD you will find the save layers box has been unchecked and you need to recheck it to save with layers. If you do not check it - then it will save flattened

                 

                 

                Note : This only happens if you uncheck Preserve Photoshop Editing Capabilities when saving the PDF.

                 

                 

                Dave