9 Replies Latest reply on Jan 16, 2018 11:53 AM by JerryPF

    OAM won't export to HTML

    JerryPF Level 1

      I successfully created interactive slideshows with Muse and audio button created in Edge Animate. Edge now struggles under the latest Mac OS, virtually unusable.

       

      Discovered how to create buttons with audio in Animate, although initially it wouldn't work properly using jpeg graphics (states didn't work) – fine with png. The .oam file imported into Muse displays and previews perfectly in the browser. When I export to .html the audio button just disappears.

       

      I went back to the original slideshows I produced 3–4 years ago. I tried to export one of the old Muse sites, and again the .oam components disappear. How can this be resolved?

       

      Also, Muse won't Quit – I have to Force Quit. Is the application not compatible with the latest Mac OS?

       

      Is the .oam no longer supported? How else can I create a simple slideshow with an interactive audio button, that I can supply to the client as .html?

        • 1. Re: OAM won't export to HTML
          Pavel Homeriki Level 5

          JerryPF  написал(а)

          How can this be resolved?

          Edge Аnimate - was an experimental program. It has big problems with cross-browser compatibility, which can not be solved.

          JerryPF  написал(а)

           

          Is the .oam no longer supported?

          You will find this in Animate CC

          • 2. Re: OAM won't export to HTML
            JerryPF Level 1

            Thanks Pavel. I'm aware Edge no longer works properly and is no longer supported by Adobe. I went on to use Animate (formerly Flash Professional) and made an interactive button. My concern is that although it Previews in Muse, it doesn't export to html, it disappears. So, I'm asking if Adobe has killed off .oam along with Edge Animate, even though Adobe Animate can still produce .oam files.

             

            I'm totally lost trying to replicate a simple task I created in the past. Even my old .oam files won't export now.

             

            I'd appreciate any suitable workaround.

             

            InDesign will create a Flash button with audio attached, but the .swf which plays the audio and all button states in Flash Player loses the audio in Muse and html.

            • 3. Re: OAM won't export to HTML
              Pavel Homeriki Level 5

              The OAM format is not suitable for creating interactive buttons and has never been suitable. Even a small OAM button is a whole separate site in the frame tag on the page of your site. That is, in order to light one small light bulb, you are using a nuclear power plant. I think if you google the query How to play the sound when you hover over the link, you can easily find a very simple solution. And hover effects you can easily do with the help of Muse.

              • 4. Re: OAM won't export to HTML
                Pavel Homeriki Level 5

                I just became interested. I found the solution and made a simple widget. You can see the example and download the widget here: Hover Audio Widget

                1 person found this helpful
                • 5. Re: OAM won't export to HTML
                  JerryPF Level 1

                  Hi Pavel. I gather this is probably more bulky than necessary, but these are the tools that my searches have led me to.

                   

                  I don't want the audio to appear in a player. I just want a simple loudspeaker icon as a button, with Up, Down and Click states that plays the audio on Down. I've seen comments about placing scripts in the head section – but I'm lost.

                   

                  What is the simplest way to add an interactive button in Muse?

                   

                  I've just discovered that I can export from Animate (Flash) to a .swf movie file, which works in both Preview and html. But I guess that won't work on platforms without Flash?

                  • 6. Re: OAM won't export to HTML
                    JerryPF Level 1

                    Thanks Pavel. I'll take a look.

                    • 7. Re: OAM won't export to HTML
                      JerryPF Level 1

                      I get a widget with a warning triangle. I can add .mp3 and .ogg, but nothing happens in preview or publish. I tried to find the instructions on how to use it.

                      • 8. Re: OAM won't export to HTML
                        Pavel Homeriki Level 5

                        First, create a graphic style for your button, for example with the name "sound".
                        2c78b359c1.png

                        Then add the file

                        • 9. Re: OAM won't export to HTML
                          JerryPF Level 1

                          Thanks Pavel. Showing my inexperience with widgets. Saves have to rely on Flash.