6 Replies Latest reply on Jan 23, 2018 10:46 AM by dancingjewel

    Problem Sorting by Capture Time

    dancingjewel

      I selected "All Photographs" under Catalog (~38,000 images), and then View->Sort->Capture Time (and it's set to Ascending). But when I scroll to the top of the Library Window, it is quite obvious that the Sort order at the beginning bears little resemblence to the Capture Time.

       

      For example (looking at the Metadata Panel, set to "Default" as I move through images), the first 8 images show a capture date/time of:

       

      1) Jun 1, 2012 at 5:09:13 PM

      2) Jun 1, 2012 at 5:09:14 PM

      3) Jun 2, 2012 at 4:25:41 PM

      4) Sep 19, 2011 at 5:17:05 PM

      5) Nov 4, 2009 at 5:14:37 PM

      6) Jun 1, 2012 at 5:09:15 PM

      7) Nov 2, 2009 at 8:35:24 PM

      8) Nov 2, 2009 at 8:35:24 PM (yes, identical to above)

       

      They jump all over the place for about 1,000 images before finally settling down and actually sorting by the Capture Time in the Metadata Panel.

       

      There has GOT to be something I am missing here, but I even checked the EXIF data in a seperate app.

       

      These are a mix of edited, scanned, original and "other" images.

       

      Any thoughts?

        • 1. Re: Problem Sorting by Capture Time
          johnrellis Most Valuable Participant

          LR has long had issues sorting some kinds of photos by capture date, though one of the issues was finally fixed after many years.  To sort this out, please answer these initial questions:

           

          1. Do Help > System Info and report the exact version number.

           

          2. Approximately when were the missorted scans imported into your catalog?

           

          3. Were any of the photos synced from LR Mobile, the new LR CC, or LR Web?

          • 2. Re: Problem Sorting by Capture Time
            dancingjewel Level 1

            1) Lightroom Classic version: 7.1 [ 1148620 ]

            Operating system: Mac OS 10

            Version: 10.12.6 [16G1114]

             

            2) Complicated, because I was consolidating libraries from multiple sources. These came from iPhoto, and were imported via the LR Plug-in this month (January 2018).

             

            3) No.

             

            And thanks!

            • 3. Re: Problem Sorting by Capture Time
              johnrellis Most Valuable Participant

              OK, that helps. 

               

              LR long had inconsistencies in the way it treated imported photos missing capture dates stored in their metadata (e.g. scans).  LR maintains a photo's capture date in multiple places in its catalog but different parts of LR failed to keep those multiple instances in sync.  This resulted in problems with sorting, filtering, and renaming by capture date.

               

              To see if that's affecting your scans, do View > View Options to ensure the capture date is showing under the thumbnails. Select a scan that may not be sorting properly and compare the date shown under the thumbnail with that shown in the Metadata panel:

              If they don't match, then that photo has been struck by the old bug.

               

              You can fix the inconsistency by selected a photo, doing Metadata > Edit Capture Time, and immediately clicking OK. This will make the date shown under the thumbnail match that shown in the Metadata panel.  You can fix an entire batch of photos by doing Metadata > Edit Capture Time followed by Change All (this does not change all of the photos to have the same date but rather is the same as doing the procedure on each photo individually).

               

              Since changes to capture date are no undoable, make sure you save a backup of your catalog before you start!

              • 4. Re: Problem Sorting by Capture Time
                dancingjewel Level 1

                I should have mentioned that I had already turned on the Capture Date/Time for both Compact and Expanded Thumbnails and compared them (I found that old bug in a forum search).

                 

                Bottom Line, they match

                 

                However, , I tried your suggestion of Metadata > Edit Capture Time and immediately clicking "Change" (not OK ) and it worked!(and, yes, I backed up my catalog first). I must have backed up the catalog 100 times during my portfolio consolidation, and will have to clear out old backups at some point. Too paranoid to do it now.

                 

                So somewhere there was a different Capture Time stored.

                 

                I will eventually get used to these little quirks, I am relatively new to LR (although been using other Adobe Apps for years), because I hopelessly clung to Aperture for so long.

                 

                Thanks!

                • 5. Re: Problem Sorting by Capture Time
                  johnrellis Most Valuable Participant

                  However, , I tried your suggestion of Metadata > Edit Capture Time and immediately clicking "Change" (not OK ) and it worked!(and, yes, I backed up my catalog first). ... So somewhere there was a different Capture Time stored.

                   

                  Going forward, you shouldn't have to do this with newly imported scans.  I tried to test the bug fix in LR 7.1 thoroughly, and it seems to (finally) be correct, knock on wood.

                  • 6. Re: Problem Sorting by Capture Time
                    dancingjewel Level 1

                    That, and I am doing all my importing to LR directly.