9 Replies Latest reply on May 15, 2008 10:01 AM by teriw

    Corrupt Project?

    teriw
      I believe my RoboHelp project file has become corrupt. As I was working in it this morning, the response time for navigating between topics became slower and slower. I would see the "Not Responding" message for a few seconds, then it would come back to life. I was making very minimal text changes and just reviewing things at the time. It went from bad to worse, and I now I cannot access the project. I get the following errors:

      - If trying to open the .xpj file from RoboHelp, I receive, "No Current Record."
      - If trying to double-click to open the .xpj file, I receive, "Runtime Error!" with the path to the RoboHelp exe file on my C drive.

      I am using RoboHelp 6 and working off a network. My project is a Web Help project. (As an aside, I always get a "CS-RCS Server Cannot be Loaded" when I open the program.)

      Although I've requested a copy of back-up files, I have a feeling it's not going to solve the problem. I tried to copy an older version of the .xpj file into my current project with the same results. I can open other projects fine.

      Any suggestions/info would be greatly appreciated.
        • 1. Re: Corrupt Project?
          Captiv8r Adobe Community Professional & MVP
          Hi teriw

          For starters, get the project off the network immediately!

          I wish I had a penny for every post I've ever seen where the answer was exactly that.

          The bottom line here is to always work locally off the C drive. Copy the files to the LAN if you need them as a backup, but always, Always, ALWAYS work off the local C drive.

          Sincerely... Rick
          • 2. Re: Corrupt Project?
            RoboColum(n) Level 5
            Wow Rick. On top of the cents you've got from "importing word docs" posts you must be rolling in it
            • 3. Re: Corrupt Project?
              Captiv8r Adobe Community Professional & MVP
              ROTFLMBO... I'm rolling in something. But it's not money!

              Rick is ducking for cover now...
              • 4. Re: Corrupt Project?
                Linux Rules Level 2
                Hello Rick, et al -

                This and other RoboHelp/HAT forums have stressed that point for years - starting back in the Blue Sky and eHelp days! Yet so many don't heed the warning.

                I had a client fly me to their site to conduct a week of training. When I arrived the first thing I learned was the PM and SysAdmin >> INSISTED << that RH be run over the network. I gave them fair warning but they decided that the PM and SysAdmin, neither of whom had EVER run RoboHelp, knew better than the consultant they hired.

                I trained their staff, gave them fair warning about the network and accepted their payment.

                Yes, they did call me down the road to find out "What do we do NOW?!" when the inevitable occurred...

                Regards,
                GEWB
                • 5. Re: Corrupt Project?
                  teriw Level 1
                  I will be trying to solve this problem by moving the files this morning when I get to the office. However, we've been working on the network with RoboHelp for years with no problem. Not that I read the books cover to cover, but is this in the RoboHelp doc or is this just something expert users have had to figure out by trial and error? None of the writers I work with were aware of ths issue.
                  • 6. Re: Corrupt Project?
                    RoboColum(n) Level 5
                    It is not really RHs problem. The issue is that RH uses an MS Access database and these are the wee beasties that have problems when run over a network. A Russian Roulette analogy is often used in this scenario. You can happily play it for ages without getting shot but sooner or later your luck will run out.
                    • 7. Re: Corrupt Project?
                      teriw Level 1
                      The project is off the network and on my C drive. Still no luck. Now whether I attempt to open from RoboHelp or by double clicking, I get the Runtime error.

                      Any suggestions? Of course this is happening right at my deadline.
                      • 8. Re: Corrupt Project?
                        HKabaker Level 2
                        Teri,
                        Did you install the RH 6 service update?

                        Have you tried rebuilding the cpd file?

                        With the project closed, and RH not running, make a backup copy of the cpd file outside the project directory. Remove the original cpd file from the directory. Launch RH and open the project. RH will make a new cpd file. You will lose some setups, such as single source layouts, but there's a good chance the problem will be fixed.

                        Harvey
                        • 9. Re: Corrupt Project?
                          teriw Level 1
                          Harvey -- thanks so much. That worked.