2 Replies Latest reply on Feb 4, 2018 4:17 AM by pixxxel schubser

    My Oil Paint option is Greyed out

    elirohith

      NumGLGPUs=1

      NumCLGPUs=1

      NumNativeGPUs=0

      glgpu[0].GLVersion="4.0"

      glgpu[0].IsIntegratedGLGPU=1

      glgpu[0].GLMemoryMB=2058

      glgpu[0].GLName="Intel(R) HD Graphics 4000"

      glgpu[0].GLVendor="Intel"

      glgpu[0].GLVendorID=32902

      glgpu[0].GLDriverVersion="10.18.10.4358"

      glgpu[0].GLRectTextureSize=16384

      glgpu[0].GLRenderer="Intel(R) HD Graphics 4000"

      glgpu[0].GLRendererID=358

      glgpu[0].HasGLNPOTSupport=1

      glgpu[0].GLDriver="igdumdim64.dll,igd10iumd64.dll,igd10iumd64.dll"

      glgpu[0].GLDriverDate="20151221000000.000000-000"

      glgpu[0].CanCompileProgramGLSL=1

      glgpu[0].GLFrameBufferOK=1

      glgpu[0].glGetString[GL_SHADING_LANGUAGE_VERSION]="1.30 - Build 10.18.10.4358"

      glgpu[0].glGetProgramivARB[GL_FRAGMENT_PROGRAM_ARB][GL_MAX_PROGRAM_INSTRUCTIONS_ARB]=[1447 ]

      glgpu[0].glGetIntegerv[GL_MAX_TEXTURE_UNITS]=[8]

      glgpu[0].glGetIntegerv[GL_MAX_COMBINED_TEXTURE_IMAGE_UNITS]=[96]

      glgpu[0].glGetIntegerv[GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS]=[16]

      glgpu[0].glGetIntegerv[GL_MAX_TEXTURE_IMAGE_UNITS]=[16]

      glgpu[0].glGetIntegerv[GL_MAX_DRAW_BUFFERS]=[8]

      glgpu[0].glGetIntegerv[GL_MAX_VERTEX_UNIFORM_COMPONENTS]=[4096]

      glgpu[0].glGetIntegerv[GL_MAX_FRAGMENT_UNIFORM_COMPONENTS]=[4096]

      glgpu[0].glGetIntegerv[GL_MAX_VARYING_FLOATS]=[64]

      glgpu[0].glGetIntegerv[GL_MAX_VERTEX_ATTRIBS]=[16]

      glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_PROGRAM]=1

      glgpu[0].extension[AIF::OGL::GL_ARB_FRAGMENT_PROGRAM]=1

      glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_SHADER]=1

      glgpu[0].extension[AIF::OGL::GL_ARB_FRAGMENT_SHADER]=1

      glgpu[0].extension[AIF::OGL::GL_EXT_FRAMEBUFFER_OBJECT]=1

      glgpu[0].extension[AIF::OGL::GL_ARB_TEXTURE_RECTANGLE]=1

      glgpu[0].extension[AIF::OGL::GL_ARB_TEXTURE_FLOAT]=1

      glgpu[0].extension[AIF::OGL::GL_ARB_OCCLUSION_QUERY]=1

      glgpu[0].extension[AIF::OGL::GL_ARB_VERTEX_BUFFER_OBJECT]=1

      glgpu[0].extension[AIF::OGL::GL_ARB_SHADER_TEXTURE_LOD]=0

      clgpu[0].CLPlatformVersion="1.2 "

      clgpu[0].CLDeviceVersion="1.2 "

      clgpu[0].IsIntegratedCLGPU=1

      clgpu[0].CLMemoryMB=1400

      clgpu[0].CLName="Intel(R) HD Graphics 4000"

      clgpu[0].CLVendor="Intel(R) Corporation"

      clgpu[0].CLVendorID=32902

      clgpu[0].CLDriverVersion="10.18.10.4358"

      clgpu[0].CLBandwidth=9.0576e+09

      clgpu[0].CLCompute=74.6716

       

      can anyone help me out how to turn on OPENCL in Photoshop

      my graphic drivers are Inte(R) HD Family graphics

        • 1. Re: My Oil Paint option is Greyed out
          Jodi_Frye Level 3

           

           

          1. Go to Photoshop Preferences > Performance > Advanced Settings.
          2. Make sure "Use OpenCL" is checked.
          3. If it is greyed out, then it means your version of OpenCL is not supported and that is the reason of Oil Paint filter being greyed out.

           

           

          Unsupported card series

          The following card series are no longer being tested and are not officially supported in Photoshop:

          • AMD/ATI 100, 200, 3000, and 4000 series
          • nVidia GeForce 7000, 8000, 9000, 100, 200, 300 series
          • Older Intel® HD Graphics (for example 2000, 3000, 4000 series) cards

          Some GL functionality may be available for these cards, but newer features won't work.

           

           

          Check your computer and see if the option to install a dedicated graphics card is available. If so you can install a new graphics card that meets the requirements. Installing the new card and drivers will simply over ride the current Intel card. When looking for a new card be sure your PSU is capable of handling it. Some require much more juice than others. Or you can just update your PSU as well.

           

          1 person found this helpful
          • 2. Re: My Oil Paint option is Greyed out
            pixxxel schubser MVP & Adobe Community Professional

            Hi elirohith,

            do you working in RGB mode?

            Because of the Oil Paint option is always grayed out eg in CMYK mode.

            1 person found this helpful