8 Replies Latest reply on May 6, 2008 7:04 AM by Lew at Chyron

    Images not appearing in finished .CHM

    Lew at Chyron
      Hi:

      Recently upgraded from RH5 to RH7.

      A little background: Our project in RH5 had an inexplicable case of the .chm file size DOUBLING after a minor accident in mistakenly editing some HTML in the "Truecode" page. That's over; not the issue here.

      A non-Adobe trainer helped me troubleshoot that, mostly by rebuilding the project from scratch IN ROBOHELP 5. Worked fine, finished .chm files back to their expected sizes, all well with the world. Imported the project into RH7 from a duplicated copy of the project folder. Got nervous about working in RH7, since our company had a major release of OUR product coming out.

      Returned to working on project in RH5. I had been properly cautioned against working on RH7-converted files, and was back in my original, fixed up RH5 project.


      Ever since then, however, SOME IMAGES DO NOT APPEAR. The result is grossly-unprofessional-looking, all-too-familiar white fields with the tedious little red "X" symbol, as on a badly built website, circa 1998. This is not OK at all.

      I have rebuilt these pages NUMEROUS times, carefully reimporting THE CORRECT IMAGE from its original location, and REIMPORTING, properly registered, added to the project, from backup locations. THESE IMAGES ARE PRESENT in the (RH5) WYSIWYG page, AND in the Topic Preview view.

      Upon Adobe "Tech Support" advice, I have hand-corrected EVERY quirky file name in the project (I inherited this project from someone who should have known better than to use special characters in file names), in order to eliminate any possible source of corruption. EVERY FILE NAME, not just images.

      File names corrected "in" RoboHelp (still version 5), and NOT in Windows, of course.

      Problem remains.

      Have once again, duplicated project folder and run project in RH7. Problem remains.

      Am ready to set my hair on fire and run screaming into traffic. Will post scheduled date and offer ticket sales.
        • 1. Re: Images not appearing in finished .CHM
          Peter Grainge Adobe Community Professional (Moderator)
          So the X5 project you are working on has not been near RH7, correct?

          If it has, then you are just wasting time as you cannot roll back. You have to revert to a copy that was never opened in RH7.

          I think though that this copy has not. Make a backup and then delete the CPD file and reopen RH.

          Let us know if that works. If it does, you'll need to see the Opening Projects article on my site.

          • 2. Re: Images not appearing in finished .CHM
            Lew at Chyron Level 1
            Hi:

            Thanks for the reply! I have been UTTERLY scrupulous about keeping precisely time-matched and points-in-my-process-matched copies of the project folder for logical, "scientific" testing in RH5 and RH7, on precisely matched content.

            I have never even tried to open an RH7-processed copy of the project in RH5 because I was warned strongly against this action.

            It boils down to this; I cleaned up, FANATICALLY, all those illegitmate filenames, ran the project again in 5, still got impermissible missing images (and I mean MORALLY impermissible, because I'm doing the right thing!)

            Then, I took that project folder, copied it, and opened the exact same ingredients, via the .xpj file, in RH7. Same missing images.

            WAIT! Left out something important in first post! Dang; this was important! I've fixed missing images, had them appear properly upon compilation, then had others that HAD been right, come out missing. Have also had reimported, re-placed images come out upon compilation following repair, and then go missing again on third or later, subsequent compilations. Maddening.

            Am EXTREMELY reluctant to delete CPD file, because the last time I did that, I lost EXTENSIVE work I'd done on TOC and Index. Not cool at all.

            Hope this wasn't too cranky; truly grateful for help. Just very frustrated.

            Thanks!
            • 3. Re: Images not appearing in finished .CHM
              Peter Grainge Adobe Community Professional (Moderator)
              You are not working across a network are you?

              What's the problem with deleting the CPD from a copy of your project?

              • 4. Re: Images not appearing in finished .CHM
                Lew at Chyron Level 1
                Again, thanks for the quick reply.

                As for working on a network, no I would rather stick a rusty spoon in my eye. This is to say that I am not working on a network.

                As for the CPD, you’re right. I know backing up the folder before surgery covers that issue, and its hazards. I will not whine anymore on the forum before trying that.

                An important question; is there any way to test this thing globally for bad outcomes such as missing images, instead of manually clicking on every index entry, linked topic and TOC entry? Didn't there used to be tools like that in website building apps, like Dreamweaver?
                • 5. Re: Images not appearing in finished .CHM
                  MergeThis Level 4
                  If you're using anti-virus software, you might ask your IT folks to completely disable it on your machine (I mean really shut it down!). See whether that helps.

                  There's really no reason for you to experience these types of problems with X5 unless your environment is unorthodox (working on a network, anti-virus preventing the free flow of data between RH and its Access database, etc.).

                  If that doesn't help, I'd try creating a new project and importing 2-3 topics at a time from the problem project. Grab a few paragraphs in each and paste them several times (to simulate normal activity) then generate and publish to entirely new locations. Keep that up until it chokes, then you can do some serious investigation of the culprit identified in this manner. If you find it, you might sanitize the content by pasting it into Notepad, then pasting that into RH and reformatting.


                  Good luck,
                  Leon
                  • 6. Re: Images not appearing in finished .CHM
                    Lew at Chyron Level 1
                    Thank you, gentlemen:

                    I took the measure of deleting the CPD, as suggested by Peter, and have had an almost suspiciously positive outcome. I'm only checking randomly, because I don't know about any whole-project-integrity tools, but so far, I've gone many more random checks into the project without finding anything amiss than before.
                    • 7. Re: Images not appearing in finished .CHM
                      Pet3689 Level 1
                      Perhaps Adobe should add a button to RoboHelp 8 HTML that displays "Fix lots of problems.", which warns the user to make a back-up first, then renames the CPD file and re-opens the project.

                      And also a "Donate." that allows users to donate money (via PayPal?) to the super-users in this forum who suggested that renaming/deleting CPD files cures lots of problems.

                      I am even wondering whether I should just rename our CPD files ones per week (or month), to prevent problems from popping up in the first place...

                      ... I am not too serious...
                      • 8. Re: Images not appearing in finished .CHM
                        Lew at Chyron Level 1


                        NEW PROBLEMS BUT MOVING IN RIGHT DIRECTION.

                        Thanks to those who have previously replied, I apparently have some problems corrected. Removal of CPD caused no output problems and seemed to fix missing-image-in-output-CHM-file problem.

                        NOW, however, when "editing" (HA!-and you'll see why in a minute), I can't open the dang topics to...well, EDIT!

                        Late Monday, I clicked one to open and edit it, and it declined to do so. I tried another, walked away for ten minutes, and RoboHelp had been kind enough to open the topic. Subsequently no other topic has opened for editing quickly enough for me to actually do any work. For all I know, they would never open at all, no matter how long I waited.

                        Am going to reinstall. I am pretty sure I was shipped 7.0.1, but will check for new updates.

                        Specific additional problem: As I may have asked elsewhere, does anyone have any idea where my Toolbox is? It does not appear, despite following instructions from RH's own online help, to open its "Pod".


                        Thanks again to those who gave very helpful advice yesterday (Monday 5/6).

                        --Lew.