2 Replies Latest reply on May 8, 2008 4:26 PM by JennHysuick

    Can't Install FB 3

    JennHysuick Level 1
      I have downloaded FlexBuilder 3, and when I go to install it, I keep getting the same error message. I'd like to install the CF extensions, and the JavaScript extensions, so I've tried installing with and without those extensions.

      The error message in the installer tells me "there was a problem installing plug-ins for Flex Builder". So, I look at the log files, and I see:
      !SESSION 2008-05-08 14:25:01.486 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.5.0_11
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_CA
      Command-line arguments: -os win32 -ws win32 -arch x86

      !ENTRY org.eclipse.equinox.app 2008-05-08 14:25:05.095
      !MESSAGE Product com.adobe.flexbuilder.standalone.product could not be found.

      !ENTRY org.eclipse.osgi 4 0 2008-05-08 14:25:05.173
      !MESSAGE Application error
      !STACK 1
      java.lang.RuntimeException: No application id has been found.
      at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer. java:236)
      at org.eclipse.equinox.internal.app.EclipseAppContainer.start(EclipseAppContainer.java:98)
      at org.eclipse.equinox.internal.app.Activator.addingService(Activator.java:112)
      at org.osgi.util.tracker.ServiceTracker$Tracked.trackAdding(ServiceTracker.java:1064)
      at org.osgi.util.tracker.ServiceTracker$Tracked.trackInitialServices(ServiceTracker.java:926 )
      at org.osgi.util.tracker.ServiceTracker.open(ServiceTracker.java:330)
      at org.osgi.util.tracker.ServiceTracker.open(ServiceTracker.java:274)
      at org.eclipse.equinox.internal.app.Activator.start(Activator.java:54)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:9 99)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextIm pl.java:993)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:9 74)
      at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260)
      at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:400)
      at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLa zyStarter.java:111)
      at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java :417)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoade r.java:189)
      at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:34 0)
      at org.eclipse.osgi.framework.internal.core.SingleSourcePackage.loadClass(SingleSourcePackag e.java:37)
      at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java :405)
      at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
      at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.jav a:83)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClassInternal(Unknown Source)
      at org.eclipse.core.internal.runtime.PlatformActivator.startAppContainer(PlatformActivator.j ava:47)
      at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:32)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:9 99)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextIm pl.java:993)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:9 74)
      at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)
      at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManage r.java:634)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java :508)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelMana ger.java:282)
      at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManage r.java:468)
      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297)

      !ENTRY org.eclipse.osgi 2 0 2008-05-08 14:25:06.267
      !MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
      !SUBENTRY 1 org.eclipse.osgi 2 0 2008-05-08 14:25:06.267
      !MESSAGE Bundle update@plugins/org.eclipse.datatools.connectivity.oda.template.ui_3.0.4.200706071.jar was not resolved.
      !SUBENTRY 2 org.eclipse.datatools.connectivity.oda.template.ui 2 0 2008-05-08 14:25:06.267
      !MESSAGE Missing required bundle org.eclipse.pde.ui_[3.2.0,4.0.0).

      !ENTRY org.eclipse.osgi 2 0 2008-05-08 14:25:06.267
      !MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
      !SUBENTRY 1 org.eclipse.osgi 2 0 2008-05-08 14:25:06.267
      !MESSAGE Bundle update@plugins/org.eclipse.datatools.connectivity.oda.template.ui_3.0.4.200706071.jar [52] was not resolved.
      !SUBENTRY 2 org.eclipse.datatools.connectivity.oda.template.ui 2 0 2008-05-08 14:25:06.267
      !MESSAGE Missing required bundle org.eclipse.pde.ui_[3.2.0,4.0.0).

      I have uninstalled my FB 2 thinking this was the problem, but it didn't change the errors.

      Please help - I need my environment back so I can keep working!

      Thanks,

      Jenn
        • 1. Re: Can't Install FB 3
          JennHysuick Level 1
          I may have solved my own install problem....I had to detach my computer from the network (pull the plug), and it installed with no issues (now I have to import my Flex 2 projects - another task for another day). The issue must be with how My Documents are mapped to a network drive rather than my local machine - I'm pretty sure I read something about the installers use of My Documents.

          But at least it installed.
          • 2. Re: Can't Install FB 3
            JennHysuick Level 1
            While I may have gotten it to install without errors, I am unable to open any FB2 projects = I'm getting the error that it cannot open the editor, and when I go to the "manage congifureation" window, I get some "/0" error - i don't have the specific error here (its on my work machine, and I am posting this from home).

            My machine is a Win XP with 2GB of RAM, and I never had these headaches with FB 2...

            Please help!