10 Replies Latest reply on Feb 16, 2018 7:37 AM by sh93430195

    Credentials problem on Chrome, Windows 10

    sh93430195

      Chrome Version 63.0.3239.132 (Official Build) (64-bit)

      Windows 10 Version 10.0.14393 Build 14393

      Flash version -- whatever is built-in to Chrome 63.0.3239.132, I can't see it because...

       

      When I load Flash Player Help , the animation does not run. In Developer Tools Console, I see the following error in flash-player.html:1:

       

      Failed to load data:text;charset=utf-8,: The value of the 'Access-Control-Allow-Credentials' header in the response is '' which must be 'true' when the request's credentials mode is 'include'. Origin 'null' is therefore not allowed access. The credentials mode of requests initiated by the XMLHttpRequest is controlled by the withCredentials attribute.

       

      If I select the info button to the left of the URL, the drop-down shows Flash - allowed by an Extension, and "Allow" to the right of it.

       

      That's my main question. I will probably open a separate issue that may or may not be related to this, in which I cannot login to vCloud director -- in middle of the page it says "vCloud Director requires Adobe Flash Player" even though Allow shows up after Flash.

       

       

        • 1. Re: Credentials problem on Chrome, Windows 10
          jeromiec83223024 Adobe Employee

          I'm not able to reproduce the problem you describe.  I see some complaints in the developer console about some of the embedded analytics libraries, but they don't have any bearing on this.

           

          The bottom line is that Flash content isn't working for you on multiple sites, despite the fact that you've enabled it.

           

          Chrome is ultimately making the decision about whether or not to run Flash Player.  We're not even getting invoked, so there's no magic that we can work from our end.

           

          The following guide might be useful:

          Use or fix Flash audio & video - Computer - Google Chrome Help

           

          I did notice that the version of Chrome you're using is a little behind.  It's probably worth updating it. 


          If you're not able to run Flash Player after following the directions in Google's guide above, a fresh install of Chrome is probably a good next step.

          • 2. Re: Credentials problem on Chrome, Windows 10
            sh93430195 Level 1

            Upgraded to 64.0.3282.167, to no avail. Have tried all of the suggestions in the link above multiple ways. At one point, Flash worked on Chrome but it doesn't anymore. I no longer get the error message above, it simply doesn't work - tells me that Flash is disabled, but Chrome thinks that it is.

            • 3. Re: Credentials problem on Chrome, Windows 10
              jeromiec83223024 Adobe Employee

              Yeah, I think you're basically looking at a clean install of Chrome at this point, then re-following the directions above to enable Flash Player.

              • 4. Re: Credentials problem on Chrome, Windows 10
                sh93430195 Level 1

                If by clean install you mean re-imaging the OS on my workstation, that isn't going to happen. I did uninstall & re-install Chrome to no avail. Will keep trying (perhaps there is some folder I need to delete -- of course I've already cleaned cache), and will post here if/when I figure it out. In the meantime will use other browsers when I need Flash. The other issue I have with WMware vCloud Director is my real issue and need to focus on that. Haven't opened a new thread on it here because I haven't been able to narrow it down. Am trying to get some outside help for this one.

                • 5. Re: Credentials problem on Chrome, Windows 10
                  jeromiec83223024 Adobe Employee

                  Yeah, I was suggesting an uninstall/reinstall of Chrome, not the OS.  Flash Player is a built-in component of Chrome, so uninstalling and reinstalling should get you back to a good state.   It probably *would* work right out of the box on a new OS, but that's cheating. 

                   

                  You really shouldn't *need* to delete anything in this instance, unless there's some kind of underlying problem with the filesystem, where the uninstallation process isn't able to delete those folders on its own.

                   

                  If you go to chrome://flash, you should see details about the Flash Player that's installed, and it will give you the location to the folder that you'd need to delete, but I think that if you checked to see that those had the same-ish timestamp as the new Chrome installation, you can be confident that they were appropriately removed and replaced.

                   

                  You *would* have to the run back through the steps to enable Flash Player from my first reply after reinstalling, since it should be back to a mostly-default state (aside from the settings it syncs back down from Google's servers, like bookmarks). 

                   

                  It *does* take Chrome a few minutes to download Flash Player after a fresh install.  It doesn't come directly bundled with Chrome.  Chrome picks up the latest in the background after first launch.  Keeping them decoupled makes life easier when one of us needs to make patches available quickly.  You'll be able to tell that it's installed if you look in chrome://flash though.

                  1 person found this helpful
                  • 6. Re: Credentials problem on Chrome, Windows 10
                    sh93430195 Level 1

                    Thanks, that was helpful, I hadn't come across chrome://flash before. Top few lines of that one:

                     

                    Google Chrome64.0.3282.167 ()
                    OSWindows UNKNOWN SP0 64 bit
                    Flash plugin28.0.0.161 <My User Info>\AppData\Local\Google\Chrome\User Data\PepperFlash\28.0.0.161\pepflashplayer.dll

                     

                    Also relieved you didn't think I need to install the OS again. The thing is that after un-installing and re-installing Chrome, I didn't have to enable the Flash -- it was already enabled, with same settings. Maybe that is a clue, and I could look at the dates of the files to see if they are getting refreshed. I would prefer to actually get Chrome with flash working again before marking the answer above as correct, because there may be some step that is needed that could help someone else.

                    • 7. Re: Credentials problem on Chrome, Windows 10
                      jeromiec83223024 Adobe Employee

                      Okay, this is less elegant than I'd like, but if you go here:

                      chrome://settings/content/flash

                       

                      And add the following to the allow list:

                      http://*

                      https://*

                       

                      Does Flash start working for you?

                       

                      Also, that switch is set to "Ask First", right?

                      • 8. Re: Credentials problem on Chrome, Windows 10
                        sh93430195 Level 1

                        Tried, did not make a difference. Yes, switch is set to "Ask First" and I can't change it -- some group policy setting I think.

                        • 9. Re: Credentials problem on Chrome, Windows 10
                          jeromiec83223024 Adobe Employee

                          If you're in a managed environment, it's totally possible that your system administrator has just disabled Flash Player wholesale.

                           

                          Do you see any interesting clues in chrome://policy/?

                          • 10. Re: Credentials problem on Chrome, Windows 10
                            sh93430195 Level 1

                            No policies set. Can use Flash in IE or Firefox. I do find it interesting that after uninstalling and re-installing, Flash settings persist.