5 Replies Latest reply on Apr 13, 2018 7:12 AM by Thielbeer

    Problem with reCAPTCHA2 in Muse

    joshwally

      http://www.joshwallace.com is my site where the forms are not sending when I include reCAPTCHA2. If I take off the reCAPTCHA2, then it sends fine, but including it prevents the form from sending for whatever reason. I entered the pair of keys and triple checked them. I entered the snippet in the header too. I even tried setting up a different reCAPTCHA2 and re-entered the new keys, but still not working. I went back and forth with my web host and they said everything on the server side is set fine. https://joshwallace.com/info.php Any ideas? Thanks!

        • 1. Re: Problem with reCAPTCHA2 in Muse
          ankushr40215001 Level 7

          Hey joshwally,

           

           

          Please reach out to your host regarding this and ask them to do a little setting mentioned in this doc - reCAPTCHA 2.0 server error -- SOLVED.

           

          Let us know if this solves your problem.

           

           

          Regards,

          Ankush

          • 2. Re: Problem with reCAPTCHA2 in Muse
            joshwally Level 1

            Yes, I did forward that to them already and they said that url_fopen was set to on.

             

            They said:

            As mentioned before, we couldn't find any issues or error logs regarding the reCAPTCHA.

            Also, the 'allow_url_fopen' is set to 'On' already. You can verify the same in the info page. Please refer: https://joshwallace.com/info.php

            I asked a friend and he said:

            For the website, it seems like it is a problem not with the captcha, but with your form processor. The google requests come back fine, but the form doesn't process.Inline image 1

            The form request is what gives the error message. The first two are success messages from Google. So you are probably getting something in that file from captcha that you don't expect, which causes the error.

            I checked everything in Muse, but don't see any issues. What could be the problem?

            • 3. Re: Problem with reCAPTCHA2 in Muse
              joshwally Level 1

              FYI, I solved this issue through my web host. They kept blaming the coding, but after wasting a bunch of time trying to figure this out, I pestered them repeatedly and they figured out what was wrong on their end.

              • 4. Re: Problem with reCAPTCHA2 in Muse
                ankushr40215001 Level 7

                Hey,

                 

                Glad they helped to fix your issue.

                 

                That's very usual for hosts to blame codes for something not working, however, Muse codes are common for all the hosts and often its some sort of setting to be done at the host end.

                 

                Do you have any idea of what exactly made it fixed, and share the same with us?

                Will get it documented and can be very useful for our other userbase as well who are dealing with such issues.

                 

                 

                Cheers,

                Ankush

                • 5. Re: Problem with reCAPTCHA2 in Muse
                  Thielbeer Level 1

                  Hello,

                   

                  would be great to know what they did to solve the problem. I have the same situation here and the provider tells me that maybe the Google keys have changed or the API does not work correct. Over 20 sites at the same moment...?

                   

                  Other sites are hosted on servers from another provider and these forms are working well. So it can only be an issue in the server settings. The PHP option for 'url_fopen' is set to 'On'. So it must be some other issue.

                   

                  Regards,
                  Olaf