1 2 Previous Next 58 Replies Latest reply on Mar 25, 2018 11:24 PM by Rob16321

    Layers don't update

    clbutler69 Level 1

      I've come across this issue lately and I have no idea how to fix it. I have experienced on my old MacBook Pro and my new and improved MacBook. When I'm working with layers Photoshop has stopped updating the appearance of the file when I turn on/off layers, use healing brush or clone brush. I have to zoom in or out for the screen to refresh to show me the current state.

       

      Has anyone else experienced this problem? Any solutions?

        • 1. Re: Layers don't update
          MediaManDan Level 1

          Yes! It's absolutely maddening. I've spent untold hours trouble-shooting video card drivers, Photoshop preferences, Uninstall then re-install PS, turning "Use Graphics Processor" on and off, re-starting untold times. I thought this might be fixed by 19.1.1 but no luck. I can't tell if this is a failing GPU or a Photoshop bug but after the trouble-shooting I'm leaning to the latter.

           

          Symptoms: Crawling ant selections disappear after making the selection, all changes to any layer doesn't refresh the canvas image OR the thumbnail until I re-size the screen image (zoom in or out). Pasting some layers don't immediately show up.

          — With Photoshop open many other software expecially Safari come to a crawl. (Photoshop is set to use 70% available memory and system memory still has 2-3 GB left)

           

           

          I am also on a MBP. (Mid 2012 Retina with GeForce GT 650M and Intel HD Graphics 4000 1536 MB) Switching between the cards makes no difference (nVidia Web Driver vs. Default MacOS driver). If it's not the hardware it has to be software.

           

          Really looking for some help, Adobe. My work has come to a complete halt. I'll do any tests, trouble-shooting or whatever to get back up.

           

          Thx

          =====

           

          This is a list of what I have done in addition to what is mentioned above:

          —Ran a full TechToolPro Hardware test including video memory - Passed

          —Started in Internet Recovery Mode and ran the hardware test - Passed

          —Updated the nVidia drivers twice. Installed the nVidia Web Driver and used it in both web driver and MacOS default driver mode.

          —Trashed Photoshop prefs, uninstalled Photoshop CC 2108, reinstalled Photoshop twice. There have been two version updates during this issue.

          -- Also checked the Apple Service and Support database using my serial number to see if this was one of the bad video cards- no mention of video card even though it is a mid 2012 MBP

          • 2. Re: Layers don't update
            atomiccherry Level 1

            I am having the EXACT same problem which started recently. I am on latest Photoshop CC release 19.1.1 using 2018 iMac. Tried several of the "fixes" listed above without any success. I have scoured forums and waited for Adobe support for over an hour with no reply. This is beyond frustrating, making it nearly impossible to work. I am clearly not the only person experiencing this MAJOR bug.

            • 3. Re: Layers don't update
              MediaManDan Level 1

              So I spent an hour with an Adobe tech on the phone and got a "partial" solution. Apparently it is a "permissions" issue with Photoshop. We created a new user within the Users & Groups of MacOS and logged in. The issue went away.

               

              When we logged back into my main user account I also noticed another strange quirk about the start-up screen. It didn't always end up on the proper screen. Sometimes it just opened and went right to the workspace, showing the palettes and canvas…other times it just ended on a black floating screen but none of the details showed up. (such as the "New" & "Open" buttons) When those details showed up, the problems were there too.

               

              But when the correct start-up screen appeared Photoshop would work correctly. Maybe you could report back if you notice the same issue?

               

              There seems to be a file or permissions issue that doesn't get removed during the PS uninstall process. That's why creating a new user seems to "solve" it. But we still need some more trouble-shooting to nail it.

              • 4. Re: Layers don't update
                atomiccherry Level 1

                I think I may have figured my own issue out. I can't say for sure just yet (still testing) but I think it was related to me recently activating Craft Manager (InVision app) tools. I had tried deactivating every other bit of software and had forgotten about that. For the moment my problem seems to be resolved. But I need to spend a bit more time in Photoshop to ensure the problem doesn't resurface.

                 

                Hope the solution you've tried works permanently for you or that you find a more permanent solution. I'll report back if my problem resurfaces and I have the chance to try your solution.

                 

                Best of luck!!!

                • 5. Re: Layers don't update
                  atomiccherry Level 1

                  Well, looks like my resolution was short lived. That was not the problem. Still experiencing the same issue. So will be trying your solution at some point over the weekend and contacting Adobe support.

                  • 6. Re: Layers don't update
                    MediaManDan Level 1

                    Well it's not a solution per se but I do know this…if the normal "start workspace with the Open and New dialog doesn't show up after opening PS then it's not going to work. I'm still doing testing to find out why it only shows up sometimes and not others.

                     

                    Good luck and let us know if you have a similar symptom

                    • 7. Re: Layers don't update
                      DigitalWheelie Level 1

                      I have a similar problem: 2017 MBP, latest version of Photoshop.

                      Sometime layers don't update, which makes Photoshop pretty damn useless.


                      Maybe it's time to go back to CS6?

                      • 8. Re: Layers don't update
                        nealmaher Level 1

                        I'm suffering from the same issues here and it's driving me insane. Just wanted to add my name to the list to hopefully grow a more of a groundswell and to let you all know that you're not crazy (or we all are). Same symptoms as are described here: selection ants disappear, layers don't update until panned or zoomed, etc. Fairly new machine with ample memory and good video card (2107 iMac, 40GB, 8GB Radeon) so shouldn't(?) be a hardware issue. Running latest PS version, 19.1.1, but was experiencing this at least a version back.

                        • 9. Re: Layers don't update
                          MediaManDan Level 1

                          So I'm the second post here and I've been testing and trouble-shooting like crazy. But I still had to get my work done so I started installing old versions one at a time until I found one that worked.

                           

                          I can report that 2017.1.3 works as expected on a MBP Retina (Mid 2013). I am using the nVidia Web driver.

                           

                          This old version of PS is installed alongside 19.1.1 and can be installed by clicking on the arrow next to Photoshop within Creative Cloud. One Caveat… because I have two versions installed some things like color settings, a few preferences, etc. are wiped out after each session and must be re-set. But compared to the nightmare of 19.1.1 I can handle that.

                           

                          Good luck guys…

                          • 10. Re: Layers don't update
                            mydwynter Level 1

                            I've been having this same problem for ages, but thought I had to switch layers to make the layer visibility change. Turns out you're right, if I zoom it works as well. I'm having the crawling ants issue, too. What's more, sometimes everything works fine for days, but then BAM, layers just stop turning on or off. It's as if I'm lulled into a false sense of security, and then a project becomes infected with the bug and only restarts will fix it.

                             

                            I'm relieved to have finally found other people with this problem. I couldn't believe I was the only one.

                             

                            Each time I update Photoshop I hope the issue will have been solved, but it hasn't. I'm glad to hear that 2017.1.3 is an option if I decide I finally can't take it anymore.

                            • 11. Re: Layers don't update
                              atomiccherry Level 1

                              Thought I'd resolved it but seems I'm still having the issue which also includes the marquee 'crawling ants' disappearing (even though still active). The only thing I've found that resolves it for me temporarily is uninstalling and reinstalling Photoshop. The problem seems to clear but always returns. Not sure if it's an internal software issue or due to a conflict with other software I'm running. Haven't really had time this week to test further.

                              • 12. Re: Layers don't update
                                mydwynter Level 1

                                I just fixed it by restarting my computer. Now that I know it's legitimately a bug, maybe eventually I'll be able to reproduce it. (Or, at least, maybe one of us will.)

                                • 13. Re: Layers don't update
                                  DigitalWheelie Level 1

                                  I just reinstalled Java and it now seems to work:

                                  Download Java for OS X 2017-001 - Java for macOS 2017-001 installs the legacy Java 6 runtime for macOS 10.13 High Sierra, macOS 10.12 Sierra, macOS 10.11 El Capitan, macOS 10.10 Yosemite, macOS 10.9 Mavericks, macOS 10.8 Mountain Lion, and macOS 10.7 Lion.

                                   

                                  Can anyone else please double-check?

                                  I did this because I needed it to run Illustrator CS6, after upgrading to High Sierra.

                                  • 15. Re: Layers don't update
                                    MediaManDan Level 1

                                    I just re-installed the Java for OSX engine and it didn't work. And to be honest I don't think it's even needed for the CC versions of Photoshop. Only older CS versions need it.

                                     

                                    As "mydwynter" discovered, re-starting works sometimes but usually not for long.

                                     

                                    A new nVidia driver came out this week-end. I installed that too without success.

                                     

                                    I would like to hear from the folks on this thread what I noticed. When the "Get Started" screen shows up at PS start-up, the app seems to work. When it goes directly to the canvas or displays just a black screen at start-up, the app does not work. I'm not sure what that has to do with our trouble-shooting but I'm just throwing it out.

                                     

                                    Still using PS 18.1.3 until this thing gets fixed.

                                    • 16. Re: Layers don't update
                                      Rob16321 Level 1

                                      I've been experiencing the very same behavior. Just going back to CC 19.0.0 did help. Starting with 19.1.0, the problem arises.

                                      There are also several threads in Photoshop Family Customer Community but no solution.

                                       

                                      Sometimes, rebooting might help. But only for a couple of minutes until the problem becomes alive again. What did Adobe's software developers change from 19.0.0 to 19.1.0 which causes just this problem? With 19.1.1. they haven't fixed it yet. That's why I cannot update Photoshop CC though Adobe's panel tells me that an update is available.

                                       

                                      It really is very frustrating. Nobody from Adobe seem to take this bug seriously and find and provide a solution. But we pay for Photoshop CC, every month!

                                       

                                      So, please fix this bug as soon as possible.

                                      • 17. Re: Layers don't update
                                        MediaManDan Level 1

                                        I just installed the new 19.1.2 last night to see if the bug has been fixed.

                                         

                                        Still broken…

                                         

                                        Not only do we pay our CC subscriptions every month but Adobe also just announced a price increase is coming. I guess it takes thousands of bug reports before it makes it onto the "to-do" list.

                                        • 18. Re: Layers don't update
                                          atomiccherry Level 1

                                          Latest version of Photoshop, issue still happening. I have to uninstall and reinstall Photoshop to "fix" the issue temporarily. Seems like I have to do that each time I need to use Photoshop lately.

                                          • 19. Re: Layers don't update
                                            Rob16321 Level 1

                                            Just wanted to confirm what @MediaManDan had written:

                                            …if the normal "start workspace with the Open and New dialog doesn't show up after opening PS then it's not going to work.

                                            Sadly, there's no chance to force PS to always showing this "start workspace" though this option was always ticked in my configuration settings. That's why I have to stay with the older version 19.0.0 until Adobe will deign to fix this serious bug.

                                             

                                            I'm a software developer myself. That's why I cannot understand what's happening here. With 19.0.0 everything was all right, starting from 19.1.0 this bug has appeared. WHAT did they alter between these versions? There they should look at.

                                            • 20. Re: Layers don't update
                                              atomiccherry Level 1

                                              I just updated tonight to the latest version 19.1.2 and all seems to be working (at least for the time being). Release notes stated fixing various critical bugs. So hoping they fixed the issue with this latest release.

                                              • 21. Re: Layers don't update
                                                atomiccherry Level 1

                                                Whelp, just saw a previous post of someone still experiencing the issue with 19.1.2. That "hope" I had was short lived.

                                                • 22. Re: Layers don't update
                                                  MediaManDan Level 1

                                                  Rob16321, thanks very much for testing and reporting back. It does two things.

                                                   

                                                  -- It helps prove we're all experiencing the same bug.

                                                  -- If Adobe is actually monitoring this thread it gives them some valuable details. (I find it very interesting that no staff or moderators have dropped into this thread yet)

                                                   

                                                  I don't know why the Get Started screen is so important to this bug but it sounds as though something is getting loaded in the start-up procedure. But in my experience "the bug" doesn't load about 5-10% of the time and PS works — usually after a full Mac re-start, etc.

                                                  • 23. Re: Layers don't update
                                                    DigitalWheelie Level 1

                                                    I think it's time to go social and public.

                                                    Tweet, Facebook, etc, about this, linking here.

                                                    On Twitter, include @Adobe  @creativecloud and @Photoshop

                                                     

                                                    Any suggestions for a hashtag?

                                                    #AdobePhotoPlop? #AdobePhotoBug? #UnCreativeCloud? #AdobeDontCare?

                                                    • 25. Re: Layers don't update
                                                      Rob16321 Level 1

                                                      Thank you very much, DigitalWheelie, for posting this bug onto twitter.

                                                       

                                                      Really astonishing that Adobe folks IMMEDIATELY read it and answered there whereas they haven't given a penny to customers reporting this bug within Adobe's own forums. I do hope they start now what they had to have started weeks ago.

                                                      • 26. Re: Layers don't update
                                                        MediaManDan Level 1

                                                        Yes. thank you!

                                                         

                                                        It's a little sad to realize it took a simple Twitter post to have the "Adobe engineers will get back to you as soon as possible." but this thread has been been going for a month!

                                                         

                                                        Why the heck do I even post here?

                                                        • 27. Re: Layers don't update
                                                          DigitalWheelie Level 1

                                                          You're very welcome.

                                                          Hope it helps us all (me included)!

                                                           

                                                          Sadly, I'll believe they'll look into this when they get here.

                                                          That could also just be a matter of keeping up appearances...

                                                          • 28. Re: Layers don't update
                                                            Pete.Green Adobe Employee

                                                            Hi all,

                                                             

                                                            Sorry about this bug where Photoshop isn't updating as frequently as it should.

                                                            We're looking into it but don't have a fix quite yet.

                                                             

                                                            We're tracking this issue here: Photoshop CC 2017: The edited image isn't updated in a window | Photoshop Family Customer Community

                                                            I've also responded there with instructions on how you can help our investigation of a bug fix if you'd like to help out.

                                                            When we have a fix, we'll also be providing that thread with an update, so click the "Me Too" button and Follow so you can be notified of any updates regarding this one.

                                                             

                                                            Regards,

                                                            Pete

                                                            • 29. Re: Layers don't update
                                                              MediaManDan Level 1

                                                              Thanks Pete. We kind of felt like we were on an island here and nobody knew. I guess we should have assumed that if we were having challenges there was another thread somewhere.

                                                               

                                                              I've already done a ton of trouble-shooting and will go over there and see if any of it applies. (The Get Started screen disappearing is one unusual symptom).

                                                              • 30. Re: Layers don't update
                                                                MediaManDan Level 1

                                                                Pete, I just took a peek at the thread you posted.

                                                                It's not very heartening to see that thread was started over a year ago. <{:-o

                                                                • 31. Re: Layers don't update
                                                                  Pete.Green Adobe Employee

                                                                  The behavior has popped up and gone away over time, I'm wondering how many are seeing this with Wacom drivers installed.

                                                                  I was able to reproduce this bug or something similar with Wacom's latest drivers, and had better results after reverting to a previous version of Wacom drivers.

                                                                   

                                                                  Are you using Wacom drivers MediaManDan? If so, can you let us know which version is currently installed?

                                                                   

                                                                  Regards

                                                                  PG

                                                                  • 32. Re: Layers don't update
                                                                    MediaManDan Level 1

                                                                    Yes I do! 

                                                                    v 6.3.27-2

                                                                     

                                                                    And I would be very happy to lose them if it meant getting PS back in line. In fact I'll do it now as a test and report back. I can do a clean  uninstall of Wacom.

                                                                     

                                                                    That might also explain why I can get PS to behave if I create a new Mac user and log on with that profile. I'll have to see of the Wacom drivers are loading for that user.

                                                                    • 33. Re: Layers don't update
                                                                      Rob16321 Level 1

                                                                      Yes, I also have a Wacom driver installed (version 6.3.10w2) which I haven't updated for years.

                                                                       

                                                                      What makes me feel a bit strange is the fact that Photoshop 19.0.0 runs without any problems whereas its successor 19.1.0 does not. But it is the very same Wacom driver installed!

                                                                       

                                                                      So something between 19.0.0 and 19.1.0 must behave differently regarding the Wacom driver. If that really should be the right track. After downgrading to 19.0.0 Photoshop runs flawlessly again. That's my current working environment.

                                                                      • 34. Re: Layers don't update
                                                                        Pete.Green Adobe Employee

                                                                        Interesting, thanks for reporting your results.

                                                                         

                                                                        In my testing, 6.3.27-2 created the behavior for me, whereas uninstalling that version and installing 6.3.25-2 fixed it for me.

                                                                        Mind testing that on your end MediaManDan?

                                                                         

                                                                        Rob, you seem to have an older driver version, would you try installing 6.3.25-2 and see if that helps you as well?

                                                                         

                                                                        Here's a link to the download page for 6.3.25-2: Driver 6.3.25-2 | Wacom Asia Pacific Customer Support

                                                                         

                                                                        Regards,

                                                                        Pete

                                                                        • 35. Re: Layers don't update
                                                                          MediaManDan Level 1

                                                                          Rob16321, That's a good observation.

                                                                           

                                                                          Unfortunately I have to report that a clean uninstall of Wacom didn't help. Well, at first it did but after the second start-up of Photoshop things were right back to before. . . no start-up screen ("Get Started") and same behavior with crawling ant selections disappearing and layers not updating any edits.

                                                                           

                                                                          Pete, when you installed the older version of Wacom did you re-start Photoshop a couple times in your testing?

                                                                          • 36. Re: Layers don't update
                                                                            DigitalWheelie Level 1

                                                                            Not to burst any bubbles, but I don't have any Wacom drivers but still experience the problem sometime.

                                                                            I have a HUION tablet and drivers, but that doesn't seem to affect anything.

                                                                            I uploaded my debug output to the other forum.

                                                                            • 37. Re: Layers don't update
                                                                              MediaManDan Level 1

                                                                              I kind of suspected that after rob16321 noticed that PS 19.0 and 19.1 were both using the same tablet driver and only one version of PS works.

                                                                               

                                                                              I just tried reverting back to Wacom 6.3.24 and as before, Photoshop works on the first start, including the start-up screen but after the re-launch it's back to no start-up screen and the same issues.

                                                                               

                                                                              Gotta say that after a few months of this I was kind of enjoying the feeling of almost having it solved. 

                                                                              • 38. Re: Layers don't update
                                                                                Pete.Green Adobe Employee

                                                                                Thanks for trying -- It's ok to have the bubble burst if it's not the solution.

                                                                                Was a shot in the dark since I was able to get it to reproduce in my testing with a particular Wacom driver.

                                                                                 

                                                                                Did I restart Photoshop a couple times in my testing?

                                                                                Maybe a couple times, but not over and over to test each launch, so it's possible the behavior would have shown itself there again in time.

                                                                                 

                                                                                Does a complete uninstall of the Wacom driver help at all with Photoshop over multiple launches?

                                                                                You'll want to use the Wacom utility found in Applications to do this.

                                                                                It's at least interesting that a different driver "fixed" it for a first launch. Seems only semi-related, and I'm not sure to what extent.

                                                                                 

                                                                                Regards,

                                                                                Pete

                                                                                • 39. Re: Layers don't update
                                                                                  DigitalWheelie Level 1

                                                                                  FWIW Thanks for actively helping, Pete. We were getting a bit desperate.

                                                                                  Here's hoping the solution is simple and found quickly...

                                                                                  1 2 Previous Next