4 Replies Latest reply on Feb 21, 2018 11:41 AM by alank99101739

    Head Warping

    raisedbytheboys

      Screen Shot 2018-02-21 at 9.55.36 PM.pngScreen Shot 2018-02-21 at 9.54.49 PM.pngScreen Shot 2018-02-21 at 9.54.25 PM.pngScreen Shot 2018-02-21 at 9.54.18 PM.png

       

      Having some weird head warping issues. I've been using the Maddy puppet as reference and I think my rigging seems fine - but I can't pinpoint as to why the mesh keeps messing up.

       

      Thanks guys! Love what you're doing adobe team!

       

      Harold.puppet - Google Drive
      Harold.psd - Google Drive

        • 1. Re: Head Warping
          alank99101739 Level 4

          Sorry, could you provide a bit more detail? E.g. what you are doing, what you see as a result, and why its not what you wanted?

           

          Most useful tip I got from these forums as step 1 with warping issues was to click the little mesh icons, to see if the meshes were fitting your character correctly. If not, warping can go strange. There is a mesh icon/button on the bottom rig screen and in the scene screen. E.g. the scene window might show a point things are warping around you did not expect, and so give you a clue where to look next.

          • 2. Re: Head Warping
            alank99101739 Level 4

            Sorry, I missed you provided a puppet!  Turn on independence for "Left Eye" and "Right Eye" (the little crown, or "+" at the start of the layer name). What is happening is the eye blinks are warping the entire head because the eyes are not independent to the head.

             

            Either that or you might be able to use blinks (set eyelid strength to zero to stop warping, and use blink replacement images instead of warping the eyelids for blinks).

            • 3. Re: Head Warping
              alank99101739 Level 4

              Turning the sunglasses off, you have a few other little problems.

               

              • Rename the "Blink" layer to "Left Blink" and "Right Blink" to pick up the auto tagging for "Left Blink" and "Right Blink" - eye blinks work better then.
              • Also on the "Left Eye" layer, remove the "Left Pupil" handle you added. You don't want that there. (Right eye is okay)
              • Rename the second "Left Pupil" to "Left Eyeball" (which should then autotag it with "Left Pupil Range"). The eyeballs should have the "Range" tags added for the eyes to move correctly. This defines how far the pupils can move.
              • Make sure the two pupils have "Left Pupil" and "Left Pupil Size" tagged (and not more).

               

              After that it works nicely for me!

              • 4. Re: Head Warping
                alank99101739 Level 4

                A stick across the shoulders in "Body" might help the head movements not causing the arms to jump around so much.

                 

                 

                You might want to decrease the "Face / Head Position Strength" property as well - e.g. 20% or less, to stop the neck stretching so badly - unless you want that effect of course! ;-)