5 Replies Latest reply on Sep 24, 2018 10:33 PM by johnrellis

    Lightroom 6: Having an issue with rotating images

    LM_H

      When I rotate my photos, they rotate correctly at first, but then shortly after they flip back to their original state all by themselves. Then, when I rotate them again, it's as if they never flipped back and so the rotation is double. For example; if my image starts out vertical, and I rotate it left once to be horizontal, shortly after it flips back to being in its original vertical position. But then, if I rotate left, again just once, my image is now upside down vertical, instead of being horizontal again. Any suggestions as to why this is happening?

        • 1. Re: Lightroom 6: Having an issue with rotating images
          Just Shoot Me Adobe Community Professional

          First thing to check/do is to turn off the GPU option on the Performance tab of the LR Preferences.

           

          See if that helps if was turned on.

          • 2. Re: Lightroom 6: Having an issue with rotating images
            lordleffler

            I've had the same problem on multiple occations. Recently, when flipping multiple images, some turned and some didn't. When clicking on one of the images that did not flip properly, after a few seconds it responds and flips as it's supposed to. However, at the same time, one of those that already were correct flips back to it's original state. Which of course is extremely annoying!

             

            The problem disappeared when I quit and restarted the program. But if there is a more sophisticated solution so that we could avoid the problem completely in the future, please let us know.

             

            Turning off the GPU as Just Shoot Me suggested unfortunately did not do anything to solve this as far as I could notice.

            • 3. Re: Lightroom 6: Having an issue with rotating images
              jannirav

              This happens to me all the time!!  I have no idea why and it's super annoying. 

              • 4. Re: Lightroom 6: Having an issue with rotating images
                johnrellis Most Valuable Participant

                [View this post in your Web browser to see the embedded screenshots.]

                This happens to me all the time!!  I have no idea why and it's super annoying.

                This can happen when you use the default import setting Build Previews: Embedded & Sidecar:

                When you first import a portrait photo, LR will show the thumbnail derived from the JPEG preview embedded in the raw photo, which often isn't rotated, e.g.

                Notice the double-arrow badge in the upper-left corner, indicating you're viewing the embedded JPEG preview.

                 

                After you do an import, LR will start generating its standard previews for these photos whenever it thinks you're not using it.  After it generates the standard preview, the thumbnail will look properly rotated:

                (Note the absence of the double-arrow badge.)

                 

                But if you rotate the photo while it's still showing the double-arrow badge (the embedded preview), first it will look like this:

                and then after a while LR generates the standard preview, and it  looks like this:

                (Note the absence of the badge.) Clearly not what you intended!

                 

                That's what it would look like if you first waited for LR to generate the standard preview and then did the rotation.  Confusing!

                 

                So the rule is: Don't rotate a photo when it is showing the double-arrow embedded-preview badge.  Either:

                 

                - Wait until LR generates a standard preview on its own (removing the badge);

                 

                - Do Library > Previews > Build Standard-Size Previews and wait until that command is finished; or

                 

                - Use the Import option Build Previews: Standard instead.

                 

                I switched to Build Previews: Standard, because embedded previews have a couple of known bugs, and some recent measurements suggest they're no longer faster than just using standard previews for the initial import.

                • 5. Re: Lightroom 6: Having an issue with rotating images
                  johnrellis Most Valuable Participant

                  Note that the embedded previews issue only occurs with LR 7 -- LR 6 and earlier don't support embedded previews.