8 Replies Latest reply on Mar 2, 2018 8:36 AM by Günter Heißenbüttel

    Turning off hyphenation

    Mauricico Level 1

      Hi everybody. Is there any trick or java code to turn off hyphenation in Adobe Muse? Long words are hyphenated wherever the program chooses, and when resizing it doesn't look nice.

       

      Thanks a lot.

       

      Mato.

        • 1. Re: Turning off hyphenation
          fotoroeder Adobe Community Professional

          It´s not where the program chooses. It depends on the margins you set and how you shrink your browser.

          If there´s not enough space, every program uses hyphenation, I guess.

          Solution can be to set your text box to not resize responsive. So you may have better control.

           

          Best Regards,

          Uwe

          • 2. Re: Turning off hyphenation
            Mauricico Level 1

            Setting the box to not to resize it´s not the spirit of Muse, that´s the main reason of my question...

             

            Thank you anyway.

            • 3. Re: Turning off hyphenation
              fotoroeder Adobe Community Professional

              To help we would really some more help. Could you provide a .muse with only one page with exactly your issue?

              You may also see this thread: Adobe Muse / different languages and auto hyphen??

               

               

              Best Regards,

              Uwe

              1 person found this helpful
              • 4. Re: Turning off hyphenation
                Mauricico Level 1

                Thank you very much Uwe. Just read the thread you mentioned, and finally understand it´s because of the browser (I`m testing the web in Safari, and in Spanish).

                 

                Here´s a pair of screenshots of my problem. To be fair, in Muse looks pretty good with no hyphenation, moving the entire word to the next line. The issue begins when testing it in the browser.

                 

                So, to fix this I´ll have to hide/show two versions of that line of text.

                 

                Thank you very much again.

                 

                Mato.

                 

                01 iPhone - 667px hor, 375px ver.PNG02 iPhone - 375px hor, 667px ver.PNG

                • 5. Re: Turning off hyphenation
                  fotoroeder Adobe Community Professional

                  The only workaround might be, to set the text to not resize and instead may need a breakpoint or keep the text "small" enough?

                  For readability on mobiles the text don´t has to be that huge. Just test it on mobiles.

                   

                  Best Regards,

                  Uwe

                  • 6. Re: Turning off hyphenation
                    Günter Heißenbüttel Adobe Community Professional

                    Mauricico: What I don’t understand:

                    Actual web browsers don’t support „real“ hyphenation.

                    Words only are separated in Muse and in browsers, if one single word is longer than the width of a text box. So there is no way out, than separating the word.

                    Looking at your screenshot, I don’t understand, why the word „REPRESENTAMOS“ is separated at all, because it is not longer than the text frame’s width. Could you try to replace the blanks between the words? Perhaps they are so called „No break spaces“ which prevent two words from being separated from each other.

                    The best way, to avoid incorrect separated words is, to use a so called soft hyphen:

                    Place the cursor between the characters, where you want to hyphenate a word, and click onto this character in the „Glyphs" panel:

                    Screen.jpg

                    This „soft hyphen“ will cause hyphenation, if necessary, and hide the hyphen, if not needed.

                     

                    Look at this small screencast:

                    2 people found this helpful
                    • 7. Re: Turning off hyphenation
                      Mauricico Level 1

                      Hi Günter. If I take for granted actual browsers don´t support real hyphenation, then my only solution is to do as fotoroeder suggested -use a text frame for the last breakpoint, and hide it in the rest of them using a new text frame-. That is not my best option, but will work.

                       

                      What I expected is the browser to take the entire long word "REPRESENTAMOS" and set it in the next line when necessary, instead of what I show on my screenshots (the word split without respecting the Spanish syllables).

                       

                      So, I´m using the idea of two text frames, unless there is the possibility to turn off hyphenation in Muse (possibility I haven´t discovered yet), which let me take the complete word to the next line with no further problems.

                       

                      I really appreciate you for bring me to notice the soft hyphen, it´s a feature I´m sure I´m going to use in the future.

                       

                      Dankeschön!

                      • 8. Re: Turning off hyphenation
                        Günter Heißenbüttel Adobe Community Professional

                        Turning off hyphenation is no option at all. First there is no hyphenation at all, there is only a word, which doesn’t fit into your text frame’s width. Real hyphenation is no option in Muse, because it is no option in actual browsers.

                        So I really don’t understand.

                        If the frame is smaller than the word, there is no way out of this behaviour, if you don’t

                        • make the text frame wider,
                        • make the font size smaller
                        • use soft hyphenation.

                        It would help a lot, if you „Show Guides" and „Show Frame Edges“ (both in „View“ menu) and give us a screenshot of this. I assume, we are dealing here with a big misunderstanding.

                        1 person found this helpful