1 Reply Latest reply on Mar 1, 2018 2:27 PM by grayD0825

    Inserted HTML code for audio clip, not working help?

    grayD0825 Level 1

      I am trying to add/or embed an audio player, I have tried all the code listed here, it is not playing and I get errors. Here is what I have tried: object/html: <embed src="20 - Hot Dog.mp3" autostart="true" loop="true" hidden="true"></embed>  then tried it this way since it is inside a folder named audio: <embed src="audio/20 - Hot Dog.mp3" autostart="true" loop="true" hidden="true"></embed> still did not work, yes I uploaded the sound file to BC, I published on BC for testing purposes. Next I tried the full pathway: <embed src="sassy hot dogs/audio/20 - Hot Dog.mp3" autostart="true" loop="true" hidden="true"></embed> still did not work. I opened up Dreamweaver HTML5 page and inserted an audio player and set all my properties in the panel, IT WORKS! So, I copied the html code:

      <audio title="sassy dog dance" preload="auto" autoplay="autoplay" loop="loop" >
        <source src="20 - Hot Dog.mp3" type="audio/mp3">
        <source src="Hot Dog Song.wav" type="audio/wav">
      </audio>

      Went back to Muse and pasted into HTML, did not work. The file is in the asset panel, I added as an upload file and uploaded to BC again. I then changed path using full pathway, did not work changed pathway to assets/20 - Hot Dog.mp3 still does not work. Then I went to Media Encoder and then tried inserting that file as well, still works in Dreamweaver, but not in Muse. Any suggestions? I DO NOT want to use a third party widget, I have several of those in Muse library, but they don't allow me to set the playback options that I want or the hidden player value.

      loop

        • 1. Re: Inserted HTML code for audio clip, not working help?
          grayD0825 Level 1

          FYI I figured it out in case anyone wants to know. This is how I did it. I deleted the HTML5 audio player from the Muse insert/HTML completely. I then uploaded the site through FTP to the clients host. I logged into the Cpanel of the host, went to the audio folder on the host opened and manually uploaded the mp3 and wav files to that folder on the directory. I went back to the Cpanel, opened up the index.html page in the host editor and inserted this code

          <audio title="sassy dog dance" preload="auto" autoplay="autoplay" loop="loop" hidden="true">

            <source src="audio/20 - Hot Dog.mp3" type="audio/mp3">

            <source src="audio/Hot Dog Song.wav" type="audio/wav">

          </audio>

          Notice the path references the directory folder the audio files are in called audio/

           

          So, there it is, the solution to placing an audio player that is hidden, autoplays, and loops. If you want it visible leave out hidden="", if you want it to play only once change to loop="false" or just leave it out, if you don't want it to auto play change to autoplay="false" or just leave out. There's more than one way to "skin" a cat, pun intended

          1 person found this helpful