3 Replies Latest reply on Mar 2, 2018 11:47 AM by norman.sanders

    Text Overlap Opacity Issue

    alphaae Level 1

      I'm working on a photoshop text that overlaps and fades into each other but you can see them mix and be darker where they overlap.

       

      I've been able to do this in the past with just lowering down the opacity of the text no problem. However, for some reason, the text is not blending like it should.

       

      The first image is what I created in After Effects.

      Screen Shot 2018-03-01 at 4.00.19 PM.png

      This second image is from Photoshop.

      Screen Shot 2018-03-01 at 3.59.53 PM.png

       

      How can I fix this?

        • 1. Re: Text Overlap Opacity Issue
          S_Gans Adobe Community Professional

          Try using a Multiply Blend mode for each layer in Photoshop, then mess with the opacities. That might help.

          • 2. Re: Text Overlap Opacity Issue
            Trevor.Dennis Adobe Community Professional (Moderator)

            I can't think of any way of doing that other than having each letter on a separate Type layer.  It sounds like a lot of messing about, but it is not actually too much trouble if you know a trick or two

            One thing I learned while setting this up is that you can't simply make the first letter and copy it eight times, and then edit each letter, but I'll come back to that.

             

            So have made your nine Type layers, move the first and last characters into position, select the Move tool. Select all the type layers and use the align tool.  This is where I ran into trouble because some characters are wider than others, and that affected the order they were distributed in to.

            Like this

            So you then need to select the Move tool, and make sure that Auto Select is unchecked, and is set to Layer

            Now Ctrl click on each character and move into position.  You can hold down the Shift key to keep the vertical alignment, but then ends up making you select multiple layers, so don't worry too much about that.  Whoops, I have missed out the H characters.

             

            If you need room to spread them out, select the Type tool and all the type layers, and change the size. Tab away from the size field, and all the layers will resize together.

            If you end up with something like this,m select all the layers again and the Move tool, and click on Align Vertical centres

            Increase the character size again to give you the overlap.  Remember, select the Type tool, all the type layers, and change the size.

            Having achieved the right degree of overlap, reduce opacity and change the colour to suite.  Here again, so long as the Type tool and all the type layers are selected, you can do both of those operations in one go.  Note you do not need to change the blend mode.  I set Multiply at the start, but I changed it to normal with no change to ho it looked.

            When you have the look you want, maybe make the type layers into a single Smart Object, and Free Transform to the size you need.  At any time you can double click the SO to edit it.  Remember if you want to make the SO wider, you'll need to add canvas in the new window the SO opens for editing.

             

            Does the reduced opacity present any problems?

            If it does, add a layer underneath the SO and fill with white.  Ctrl click the SO to load it as a selection, and add a layer mask to the white layer

            • 3. Re: Text Overlap Opacity Issue
              norman.sanders Adobe Community Professional & MVP

              Composite.png

              Open a file a type a word (Fig. 1)

              Choose Type > Convert to Shape

              Click in a clear area wit\ the Path Selection tool then click on the first letter to be moved

              Use the keyboard arrows to slide the letter left to overlap. Repeat with the other letters (Fig 2)

              When completed, click on the Path Selection tool again

              Duplicate the layer

              Turn off the top.layer and return to the layers below it

               

              Still working with the Path Selection tool,

              In the Options bar choose hold down the overlapping boxes and choose Merge Shape Components

              Choose Edit > Define Custom Shape (Fig 3)

              Turn off the layer

               

              Return to the top layer (Fig 4)

              Click ion the first moved letter, go to the overlapping boxes and choose Exclude Overlapping Shapes

              Repeat for each of the other letters that had been moved (Fig 5)

              Finally choose Merge Shape Components from the overlapping boxes again

              Click on the Path Selection\ tool again so the control points are visible

              Choose Edit > Define Custom Shape (Fig 6)

               

              Open a new file and draw the two Shapes. Apply Edit > Transform refine register  (Fig 7 & 8)