4 Replies Latest reply on Oct 14, 2008 3:59 AM by BobDzim

    Audio and Video Glitches

    znich
      Hi,
      I deployed a flash video on a bunch of sites about a year ago and it worked fine.

      A few weeks ago, all of a sudden on all the sites (different hosts, servers etc) the audio has started glitching out and occasionally the video, too. I can only assume this was caused by an update to flash, though I can't be certain. It's a really simple flash video player that loads and external .swf file and plays it. I have no idea what to do at this point.

      You can watch the video at: http://mma4millions.com/video.php
      (The website hasn't officially launched yet so there are other problems as well, but just pay attention to the video)

      It plays fine on the flash player that comes with the flash app, but not once loaded to a server through a browser.

      Any help would be appreciated. Thanks!
        • 1. Re: Audio and Video Glitches
          RossRitchey Level 4
          How long is the loaded SWF video?

          I played it for about a minute, and didn't experience any glitches, but I know that audio/video glitches happen frequently with very long SWF's (especially if they are large file sizes). This has something to do with the limited buffering abilities for loading SWFs. I typically recommend changing this to an FLV that progressively downloads.
          • 2. Re: Audio and Video Glitches
            znich Level 1
            It's quite long. Can't remember the exact length, though. The weird thing is that it worked fine for a year and now isn't.

            It must be buffering problems. Every couple seconds the audio sounds like it skips forward a fraction of a second a couple times in succession. I'll try converting to FLV.

            • 3. Re: Audio and Video Glitches
              BobDzim
              If you hear anything further on this I'd be very interested. Ever since version 9 the sound on some files sounds like it speeds up or slows down for a fraction of a second. I have tried updating drivers to no avail. I try to revert back to version 8 but the presentations do not work now because they say you need the latest version of flash. Is there a way to turn that version check off?
              Thanks
              • 4. Re: Audio and Video Glitches
                BobDzim Level 1
                If you hear anything further on this I'd be very interested. Ever since version 9 the sound on some files sounds like it speeds up or slows down for a fraction of a second. I have tried updating drivers to no avail. I try to revert back to version 8 but the presentations do not work now because they say you need the latest version of flash. Is there a way to turn that version check off?
                Thanks