18 Replies Latest reply on Sep 30, 2018 7:11 PM by view836

    Issue applying 6.14 update to Lightroom 6.0

    Melinda Woo

      Hi, I can't seem to get my Lightroom 6 to upgrade to 6.14. I've downloaded the 6.14 upgrade as well as  the 6.13 and the 6.12 but every time I run the AdobePatchInstaller.exe file for any of these updates, I receive the following message:

       

      "This patch is not applicable for you. Please check for updates from the Help menu in your product to see a list of latest updates available."

       

      In Lightroom, I've click on Help>Updates and after searching for a few seconds it tells me that Lightroom is up to date. However when I look at the System Info, it shows that I'm still only running Lightroom 6.0. What's strange is that it's showing that my Op System is 8.1, but I definitely have 10 Pro installed.

       

      Lightroom version: 6.0 [1014445]

      License: Perpetual

      Operating system: Windows 8.1 Business Edition

      Version: 6.3 [9600]

      Application architecture: x64

      System architecture: x64

       

      This is very frustrating as I need the updated camera profiles, but I don't want to have to upgrade to CC or CC Classic.

      Any help would be appreciated, thank you.