14 Replies Latest reply on Mar 24, 2018 3:53 PM by ravenise

    Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)

    ravenise Level 1

      The hang is variable and random upon each encode operation; Sometimes 0%, sometimes 42%, sometimes 92%. Often hangs at 0% prior to utilizing any CPU forcing me to forcefully close and restart the program. The program often hangs while moving around the timeline as well (says program is not responsive).

       

      Exporting often works when lowering export resolution down from 1920 to 1280; disabling maximum render quality & maximum depth.

       

      I have deleted cache files. I have disabled all overclocking on my system. I have updated all adobe products and addons to the latest.

       

      Video Card: Nvidia 660 GTX.

       

      Project includes the following plugins: The latest Boris FX Sapphire & Continuum;

       

      Any suggestions?

        • 1. Re: Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)
          ravenise Level 1

          In Ppro, If I cancel the hung encode and start it again without closing / rebooting premiere entirely; it hangs at 0%. Apparently at a similar state as it was during the initial encode.

          • 2. Re: Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)
            ravenise Level 1

            I saw an error on the bottom right, exception occurred with plugin: S_glow; the closing Premiere doesn't close premiere entirely; I must force close it and its associated programs via task manager.

            • 3. Re: Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)
              ravenise Level 1

              Many users were having issues with Sapphire and GPU encode enabled; So I tested to see if disabling sapphires GPU utilization would result in a successful encode.

               

              Mac

              /usr/discreet/sparks/sapphire_*, you have a file called s_config.text.

              Windows
              C:\Program Files\GenArts\SapphireAE\s_config.text


              Start+R %ProgramFiles%\GenArts\SapphireAE

               

              Just edit the line that says use_gpu=yes to use_gpu=no.

               

              gpu=no Test result was:  Much slower encode, STILL hangs.

               

              Optional for those this helps: Can enable GPU for faster albeit somewhat buggy timeline editing & previews, and disable for final encode.

              • 4. Re: Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)
                ravenise Level 1

                Primary machine is a custom desktop PC Windows 7 64 SP1; Using a different computer (dell laptop) with Windows 10 with the same project imported results in the same activity; using sapphire 11.0.1, Ppro 12.0.1; opened a thread on BorisFX on this very issue: https://forum.borisfx.com/t/sapphire-low-level-exception-hanging-on-encode/3623

                • 5. Re: Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)
                  ravenise Level 1

                  The encode began resuming on the laptop after pausing the encode; unplugging the HDD the project was located; plugging it back in and resuming the encode; I had also forced closed “Adobe After Effects” in the task manager soon after plugging the hard drive back in, and prior to its resumption.

                  • 6. Re: Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)
                    ravenise Level 1

                    It originally hung at 42% on s_glow sequence (with warp stabilizer). Now it has hung again at 74% on the Windows 10 laptop in the midst of BBC rays dissolve transition on top of two nested sequences which include S_Glow and adobe warp stabilizer. In the first half of the transition, the nested sequence on the surface of the main timeline has bcc color correction enabled; inside that nested sequence is warp stabilizer and S_Glow. The nested sequence (on the surface of the main timeline) in the second half of the transition, has no effects; and it includes another nested sequence, ON this second nest, speed has been set to 50% with optical flow enabled, and S_Glow enabled. INSIDE the second nested sequence adobe Warp stabilizer is enabled at 50 percent smoothness with Subspace warp and detailed analysis.

                    • 7. Re: Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)
                      ravenise Level 1

                      After 30 minutes the video resumed on the aforementioned transition for 3-4 frames then hung again.

                      • 8. Re: Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)
                        ravenise Level 1

                        Correction, Mac config file located here:

                        /Applications/GenArtsSapphireAE/config/s_config.text

                         

                        Often restarting the encoding of a project it hangs randomly on variable points, its not always the same, therefore if possible (in adobe and other apps), a very simple work around for BorisFX would be an option to restart the encoding of a particular transition or clip segment if it hangs or encounters an error; This may eliminate a massive segment of these errors; or at least time wasted due to hangs.

                        • 9. Re: Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)
                          ravenise Level 1

                          ad71f81873f374e7ce419644392e479c19b0f87c_1_666x500.JPG

                          Output preview on the Laptop how shows one large red background; only a tiny segment of the video footage is visible on the right.

                          • 10. Re: Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)
                            ravenise Level 1

                            Confirmed, the Laptop video completed after 25 hours with many bugs and corruptions. Red frames, blurry transitions, flickery blurry segments, and audio timing issues.

                            • 11. Re: Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)
                              ravenise Level 1

                              So I gave a copy of my project to BorisFX for them to debug, and the result was the following, quote:

                               

                              "Hi canyoncomputers,

                               

                              I was able to render out the clip fine using my computer. I had to install AE_ADBE FC Pro 2.1 plugins. I also had to remove the Final.mp4 clip at the beginning of the project since I was missing that media.

                               

                              What I did notice during the render was that my memory usage was pretty high. My system memory was going up to 14GB out of 16 GB and GPU usage was 2.5 GPU out of 8GB.

                               

                              What Sapphire does is that it uses the GPU to speed up render while it still have enough GPU memory and if it runs out then it will switches over to CPU. This memory is shared between Sapphire, Premiere, your PC, and any other filters you’re using. In your case I believe that all your GPU memory is used up which is indicated by your logs. This causes Sapphire to switch over to CPU memory. However if you’re running out of your system memory as well then you’ll experience slowdown.

                               

                              A few things you can do is upgrade your GPU. I know that graphics card can be costly so another route you can also try is by upgrading your system memory. As I recalled you’re running with 8GB. If you upgrade it to 16GB then it might help with the rendering. Another option would be to just pre-comp or render out the various sections of your project so it would speed up with the whole rendering process in your final project.

                               

                              Thanks,

                              Linh"

                              • 12. Re: Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)
                                ravenise Level 1

                                So when sapphire runs low on GPU memory it results in  "S_Glow" low level exception errors.  So I guess BorisFX requirements for sapphire have risen to 16 GB ram, and, 4GB video memory. I don't mind having slow downs, but my issue is I am running into errors that cause corruption and a failing project; Rather than the end user being forced to pay thousands of dollars for a buggy application, then upgrades, it would be much better Boris tweaked Sapphire to work properly, and fix these bugs. Disabling GPU use in sapphire resulted in the same bugs. 

                                 

                                Sun Dec 24 17:39:32 2017: SBuild/sapphire-ae/final-em64t/core/execute-kernels.cu:34: launching kernel: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: SBuild\sapphire-ae\final-em64t\primitives\mem-manager.cxx:924: CUDA error: out of memory

                                Sun Dec 24 17:39:32 2017: S_Glow failed execution plan on 1920 x 1080 clip with 8 bit depth (temps 1920x1080)

                                 

                                That's a lot of money they are expecting their users to spend on a simple bug.

                                 

                                Gee Thanks.

                                • 13. Re: Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)
                                  ravenise Level 1

                                  The only work around I found was the following: pre-compose, create copy of the original sequence or just drag and drop the sequence onto an empty timeline; this results in a nested sequence of the original; chop it up into manageable sizes (may not be absolutely necessary); encode using cineform: yuv 10-bpc, at a quality of 3. This is what used but rgba 12-bcp + alpha may work also at a higher quality setting. This resulted in a professional quality precomp with zero errors, which I successfully re-encoded later as h265 and h264

                                  • 14. Re: Video Encoder Hangs in PPro & Media Encoder 12.0.1 (Windows 7)
                                    ravenise Level 1

                                    Not a bug fix but at least this works!