2 Replies Latest reply on Mar 14, 2018 7:03 AM by mmmarc

    Android build fail

    mmmarc Level 1

      Hello,

      When I build (PGB) the zip. I get an error. Below the logs. Who could help me?

       

      Build Date: 2018-03-13 15:16:26 +0000

      --------------------------------------------------------------------------------

      PLUGIN OUTPUT

      --------------------------------------------------------------------------------

      Fetching plugin "cordova-plugin-device" via npm

      Installing "cordova-plugin-device" at "2.0.1" for android

      Fetching plugin "cordova-plugin-inappbrowser" via npm

      Installing "cordova-plugin-inappbrowser" at "2.0.2" for android

      Fetching plugin "cordova-plugin-statusbar" via npm

      Installing "cordova-plugin-statusbar" at "2.4.1" for android

      Fetching plugin "cordova-plugin-console" via npm

      Installing "cordova-plugin-console" at "1.1.0" for android

      Fetching plugin "cordova-plugin-geolocation" via npm

      Installing "cordova-plugin-geolocation" at "4.0.1" for android

      Plugin doesn't support this project's cordova-android version. cordova-android: 6.2.3, failed version requirement: >=6.3.0

      Skipping 'cordova-plugin-geolocation' for android

      Fetching plugin "cordova-plugin-network-information" via npm

      Installing "cordova-plugin-network-information" at "2.0.1" for android

      Fetching plugin "cordova-plugin-splashscreen" via npm

      Installing "cordova-plugin-splashscreen" at "5.0.2" for android

      Fetching plugin "cordova-plugin-dialogs" via npm

      Installing "cordova-plugin-dialogs" at "2.0.1" for android

      Fetching plugin "pushwoosh-pgb-plugin" via npm

      Installing "pushwoosh-cordova-plugin" at "7.3" for android

      Subproject Path: CordovaLib

      Fetching plugin "cordova-plugin-whitelist" via npm

      Installing "cordova-plugin-whitelist" at "1.3.3" for android

       

        This plugin is only applicable for versions of cordova-android greater than 4.0. If you have a previous platform version, you do *not* need this plugin since the whitelist will be built in.

      Fetching plugin "nl.kingsquare.cordova.background-audio" via npm

      Installing "nl.kingsquare.cordova.background-audio" at "1.0.1" for android

      Fetching plugin "cordova-plugin-socialsharing" via npm

      Installing "cordova-plugin-socialsharing" at "4.3.81" for android

      --------------------------------------------------------------------------------

      COMPILE OUTPUT

      --------------------------------------------------------------------------------

      :wrapper

       

      BUILD SUCCESSFUL in 2s

      1 actionable task: 1 executed

      Subproject Path: CordovaLib

      The Task.leftShift(Closure) method has been deprecated and is scheduled to be removed in Gradle 5.0. Please use Task.doLast(Action) instead.

      at build_wx4ai6lzo5hhniiuvklm5yon.run(/project/build.gradle:137)

      The JavaCompile.setDependencyCacheDir() method has been deprecated and is scheduled to be removed in Gradle 4.0.

      Incremental java compilation is an incubating feature.

      The TaskInputs.source(Object) method has been deprecated and is scheduled to be removed in Gradle 4.0. Please use TaskInputs.file(Object).skipWhenEmpty() instead.

      File /.android/repositories.cfg could not be loaded.

      Checking the license for package Solver for ConstraintLayout 1.0.2 in /opt/android-sdk/licenses

      Warning: License for package Solver for ConstraintLayout 1.0.2 not accepted.

      Checking the license for package ConstraintLayout for Android 1.0.2 in /opt/android-sdk/licenses

      Warning: License for package ConstraintLayout for Android 1.0.2 not accepted.

       

      FAILURE: Build failed with an exception.

       

      * What went wrong:

      A problem occurred configuring root project 'project'.

      > You have not accepted the license agreements of the following SDK components:

        [ConstraintLayout for Android 1.0.2, Solver for ConstraintLayout 1.0.2].

        Before building your project, you need to accept the license agreements and complete the installation of the missing components using the Android Studio SDK Manager.

        Alternatively, to learn how to transfer the license agreements from one workstation to another, go to http://d.android.com/r/studio-ui/export-licenses.html

       

      * Try:

      Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

       

      BUILD FAILED

       

      Total time: 5.218 secs

      Error: /project/gradlew: Command failed with exit code 1 Error output:

      FAILURE: Build failed with an exception.

       

      * What went wrong:

      A problem occurred configuring root project 'project'.

      > You have not accepted the license agreements of the following SDK components:

        [ConstraintLayout for Android 1.0.2, Solver for ConstraintLayout 1.0.2].

        Before building your project, you need to accept the license agreements and complete the installation of the missing components using the Android Studio SDK Manager.

        Alternatively, to learn how to transfer the license agreements from one workstation to another, go to http://d.android.com/r/studio-ui/export-licenses.html

       

      * Try:

      Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

        at ChildProcess.whenDone (/project/cordova/node_modules/cordova-common/src/superspawn.js:169:23)

        at emitTwo (events.js:106:13)

        at ChildProcess.emit (events.js:191:7)

        at maybeClose (internal/child_process.js:877:16)

        at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)