12 Replies Latest reply on Mar 20, 2018 11:03 AM by Todd Shaner

    New MBP2017 15" / Fans going crazy when browsing photos

    paulwieczorek Level 1

      We just bought the latest MBP 15" 2017 max spec. Copied the files to the new 1TB SSD of the new MBP, installed latest Lightroom Classic CC, imported all the photos to new catalog and built all smart previews. Whenever I try to browse the photos, they browse lighting fast (I can even scroll through team with ease) but the fans goes crazy and the CPU usage goes up to 200-400%.

       

      No CC sync, no smart previews rendering in the background - screenshots attached. Also tried to reset preferences.

       

      Latest version of High Sierra and Lightroom Classic.

       

      What's going on? I can't stand this noise!

       

       

      Screen Shot 2018-03-14 at 00.06.12.png

      Screen Shot 2018-03-14 at 00.06.22.png

      Screen Shot 2018-03-14 at 00.19.18.png

       

      Lightroom Classic version: 7.2 [ 1156743 ]

      License: Creative Cloud

      Language setting: en-PL

      Operating system: Mac OS 10

      Version: 10.13.3 [17D47]

      Application architecture: x64

      Logical processor count: 8

      Processor speed: 3,1 GHz

      Built-in memory: 16 384,0 MB

      Real memory available to Lightroom: 16 384,0 MB

      Real memory used by Lightroom: 5 593,5 MB (34,1%)

      Virtual memory used by Lightroom: 8 978,2 MB

      Memory cache size: 774,4MB

      Internal Camera Raw revision: 894

      Maximum thread count used by Camera Raw: 5

      Camera Raw SIMD optimization: SSE2,AVX,AVX2

      Camera Raw virtual memory: 4566MB / 8191MB (55%)

      Camera Raw real memory: 4569MB / 16384MB (27%)

      Displays: 1) 3360x2100

       

      Graphics Processor Info:

      Metal: AMD Radeon Pro 560

       

      Application folder: /Applications/Adobe Lightroom Classic CC

      Library Path: /Users/eighty9/Pictures/Lightroom/Lightroom Catalog.lrcat

      Settings Folder: /Users/eighty9/Library/Application Support/Adobe/Lightroom

       

      Installed Plugins:

      1) AdobeStock

      2) Aperture/iPhoto Importer Plug-in

      3) Canon Tether Plugin

      4) Facebook

      5) Flickr

      6) Nikon Tether Plugin

       

      Config.lua flags: None

       

      AudioDeviceIOBlockSize: 512

      AudioDeviceName: Built-in Output

      AudioDeviceNumberOfChannels: 2

      AudioDeviceSampleRate: 44100

      Build: 10.0x7

      CoreImage: true

      GL_ACCUM_ALPHA_BITS: 0

      GL_ACCUM_BLUE_BITS: 0

      GL_ACCUM_GREEN_BITS: 0

      GL_ACCUM_RED_BITS: 0

      GL_ALPHA_BITS: 8

      GL_BLUE_BITS: 8

      GL_DEPTH_BITS: 24

      GL_GREEN_BITS: 8

      GL_MAX_3D_TEXTURE_SIZE: 16384

      GL_MAX_TEXTURE_SIZE: 16384

      GL_MAX_TEXTURE_UNITS: 8

      GL_MAX_VIEWPORT_DIMS: 16384,16384

      GL_RED_BITS: 8

      GL_RENDERER: AMD Radeon Pro 560 OpenGL Engine

      GL_SHADING_LANGUAGE_VERSION: 1.20

      GL_STENCIL_BITS: 8

      GL_VENDOR: ATI Technologies Inc.

      GL_VERSION: 2.1 ATI-1.60.26

      OGLEnabled: true

      GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod

        • 1. Re: New MBP2017 15" / Fans going crazy when browsing photos
          Sahil.Chawla Adobe Employee

          Hi Paulwiezorek,

           

          That's definitely what should not be happening, let us help you make this right. Could you please let us know are you using the latest version of Lightroom Classic CC which is 7.2?

           

          Also, is this CPU usage spike permanent or does it drop down after a few minutes?

           

          Could you make sure that sync is off?

           

          Regards,

          Sahil

          • 2. Re: New MBP2017 15" / Fans going crazy when browsing photos
            paulwieczorek Level 1

            Sahil, I'm more thank thankful for Your willingness of help but You didn't read what I said and are trying to buy You time. I said everything is updated to the latest versions. I said and put it on screenshots the sync is off. I have the experience will all the supports this world has and I know the first things they ask me is "did You update to the latest version?".

             

            Nevertheless, thank You for taking Your time and answering my post. The fans and CPU usage goes rage no matter if I browse normal or in light mode (L).

             

            Screen Shot 2018-03-16 at 08.33.29.png

            Screen Shot 2018-03-16 at 08.50.01.png

            Screen Shot 2018-03-16 at 08.50.07.png

            • 3. Re: New MBP2017 15" / Fans going crazy when browsing photos
              Todd Shaner Adobe Community Professional & MVP

              You may have a manufacturing defect in your new MBP or something may be blocking the cooling ports. Install the below CPU monitor and see how hot it gets with Lightroom open, but not doing anything. Give it time to stabilize and then take a screenshot of the Power Gadget panel. Next start browsing images and when the fans become audible take another screenshot of the Power Gadget panel. Post both screenshots in a reply here.

               

              Intel® Power Gadget | Intel® Software

              1 person found this helpful
              • 4. Re: New MBP2017 15" / Fans going crazy when browsing photos
                paulwieczorek Level 1

                Todd Shaner thank You much for the advice! Posting results below. I still think there's a problem in Lightroom's code - please compare how much CPU it uses when browsing compared to rendering of many objects in Dimension CC. Also look at the memory hog Lightroom creates - even now, after 20mins of absolutely no action, LR still takes 6GB of memory.

                 

                lightroomproblem.png

                • 5. Re: New MBP2017 15" / Fans going crazy when browsing photos
                  Todd Shaner Adobe Community Professional & MVP

                  Somethings wrong with your laptops cooling system. With LR open and not doing anything it only drops to 55° C, which is high for system idle. At the start of browsing it jumps to 97.8° C. and peaks at almost 100° C, which is the Intel spec maximum Tjunction temperature. This would explain the high fan speed, but it should be able to keep the package temperature lower. Take a look at the tips here and make sure the laptop is on a flat surface with nothing obstructing the air inlet/outlet openings.

                   

                  Keep your Mac notebook within acceptable operating temperatures - Apple Support

                   

                  Your screenshot shows 'Previous Import' 1277 photos, which may indicate you're reviewing recently imported image files. Preview building and other "background" tasks may be running. Try selecting all of the image files and then Library> Previews> Build Standard Previews or 1:1 if browsing at 1:1 Zoom view.  also apply the following Preferences setting Performance> uncheck 'Generate Previews in Parallel. In the Catalog Settings> Metadata uncheck 'Automatically write changes into XMP.' also make sure all three background tasks are Paused. Let the preview building process complete and then run the same browsing test with Intel Power Gadget.

                   

                  1 person found this helpful
                  • 6. Re: New MBP2017 15" / Fans going crazy when browsing photos
                    Todd Shaner Adobe Community Professional & MVP

                    On further investigation over-heating appears to be a common problem on newer MBPs 2015 and later. The above suggestions should still help to reduce CPU usage and resulting rise in fan speed.

                     

                    https://www.google.com/search?num=100&client=firefox-b-1&ei=BSGsWpzNLc-c5wKpnJrYCA&q=macBo ok+Pro+heat+lightroom&oq=macBo…

                    1 person found this helpful
                    • 7. Re: New MBP2017 15" / Fans going crazy when browsing photos
                      paulwieczorek Level 1

                      Todd Shaner thank You for such thorough contribution into my problem. You're actually saving my life, sir. We bought this MBP a week ago so I could work abroad and in bed (due to some private problems) and thanks to You I found it's really defected. I've read all the links You gave me and also done all the troubleshooting steps Apple recommends.

                       

                      No any problem in hardware test, resetting the SMC and NVRAM helped nothing. Also, every time we import any photos to library, the first thing we do is build smart previews since they take much less disks space but I'm in the process of building standard ones, following Your advice.

                       

                      I'm posting these screenshots since You can find them interesting (please notice the inconsistency in fans speed):

                       

                      lightroomproblem_temps.png

                      • 8. Re: New MBP2017 15" / Fans going crazy when browsing photos
                        Todd Shaner Adobe Community Professional & MVP

                        paulwieczorek  wrote

                         

                        We bought this MBP a week ago so I could work abroad and in bed (due to some private problems) and thanks to You I found it's really defected. I've read all the links You gave me and also done all the troubleshooting steps Apple recommends.

                        Did you try these tests with the MBP on a flat table top surface with the AC adapter hooked up? LR 1:1 Preview building alone with no other LR activity or background tasks running should not push the CPU to a continuous 100% CPU usage. I just tested my Windows 7 desktop system with 17-860 quad-core and the CPU usage shows an "average" of ~50-60% with peaks to 100% and maximum core temperature of ~60°C (see below).

                         

                        Let's try rolling back to LR 7.1 and run the test again. Make sure to backup your catalog file(s). Open the Creative Cloud app, click on the Apps tab, click on the down-arrow next to Lightroom Classic CC and 'Install' 7.1.

                        • 9. Re: New MBP2017 15" / Fans going crazy when browsing photos
                          paulwieczorek Level 1

                          Did you try these tests with the MBP on a flat table top surface with the AC adapter hooked up?

                          Todd Shaner this was, of course, only a figurative expression I never work from bed literally - I need flat surface to put my Wacom tablet or just for sake of it - I feel more motivated when sitting straight at the table. Also, I've read the links You gave me, I know where fan vents are. Yes, I did the tests with MBP laying flat on flat hard surface, connected to power AND I did open the window so the room was cooled to around 15-16*C (snowing outside).

                           

                          When Previews are already rendered, the fans starts only from time to time BUT the temp while browsing still oscillates around 70*C.

                           

                          Also, totally by accident, I found the bug - when browsing through with right arrow in Library mode, the view changes from Loupe view to Grid view very often. Very annoying.

                           

                          Downloading the 7.1 right now, will post the results.

                          • 10. Re: New MBP2017 15" / Fans going crazy when browsing photos
                            Todd Shaner Adobe Community Professional & MVP

                            paulwieczorek  wrote

                             

                            Yes, I did the tests with MBP laying flat on flat hard surface, connected to power AND I did open the window so the room was cooled to around 15-16*C (snowing outside).

                            You know what they say about assuming something so I had to ask.

                             

                            paulwieczorek  wrote

                             

                            When Previews are already rendered, the fans starts only from time to time BUT the temp while browsing still oscillates around 70*C.

                            That's not too bad so it's preview building that's really the problem. You might want to look at using 'Embedded & Sidecar' Import module FIle Handling> Build Previews option.

                             

                            Embedded Preview workflow in Lightroom Classic CC

                             

                            After you've culled and then finished editing the image files from a shoot you can select all and build Standard or 1:1 Previews when your not using the laptop (i.e. dinner, break, etc.). I use 'Embedded & Sidecar' import previews with Canon raw files and it it speeds my workflow.

                             

                            paulwieczorek  wrote

                             

                            Also, totally by accident, I found the bug - when browsing through with right arrow in Library mode, the view changes from Loupe view to Grid view very often. Very annoying.

                            Strange! I can't see this behavior on my Windows 7 system with LR 7.2. It'll be interesting to see if 7.1 behaves differently.

                            1 person found this helpful
                            • 11. Re: New MBP2017 15" / Fans going crazy when browsing photos
                              paulwieczorek Level 1
                              You know what they say about assuming something so I had to ask.

                              Sure thing!

                               

                              That's not too bad so it's preview building that's really the problem. You might want to look at using 'Embedded & Sidecar' Import module FIle Handling> Build Previews option.

                               

                              Embedded Preview workflow in Lightroom Classic CC

                               

                              After you've culled and then finished editing the image files from a shoot you can select all and build Standard or 1:1 Previews when your not using the laptop (i.e. dinner, break, etc.). I use 'Embedded & Sidecar' import previews with Canon raw files and it it speeds my workflow.

                              That's new and it's a nice way to speed up the workflow but to be honest, we didn't put $4500 into laptop to have to use workarounds. My old MBP 13" mid-2012 renders with no fan effect.

                               

                              Thank You for the advice with LR 7.1, it's def operating better in terms of performance. I've recorder a video while editing photos where I check temps from time to time - if You would be interested, here's the link (scroll through the slow parts): Dropbox - LR_temps.mov

                               

                              Also I've done additional tests on max spec iMac 5K 27" (late 2015) and the idle temps are around 37-40*C with many apps opened, while when importing and building 1:1 previews at the same time, they go to 70*C-ish. Of course iMac has better spec and cooling.

                               

                              Screen Shot 2018-03-20 at 16.12.20.png

                               

                              The question remains - are the idle temps of our new MBP standard or should we replace it? *wondering*

                              • 12. Re: New MBP2017 15" / Fans going crazy when browsing photos
                                Todd Shaner Adobe Community Professional & MVP

                                paulwieczorek  wrote

                                 

                                That's not too bad so it's preview building that's really the problem. You might want to look at using 'Embedded & Sidecar' Import module FIle Handling> Build Previews option.

                                That's new and it's a nice way to speed up the workflow but to be honest, we didn't put $4500 into laptop to have to use workarounds. My old MBP 13" mid-2012 renders with no fan effect.

                                 

                                You shouldn't consider using Embedded and Sidecar Import previews a workaround. When images are imported the first thing you'll want to do is cull and perhaps keyword. With Canon and Nikon cameras the full-size embedded preview is more than adequate for this purpose and even allows 1:1 Zoom view to rate and cull images based on sharpness. There's no need to wait for preview building until AFTER you've completed editing the image files and want to do further reviewing and rating in the Library module. I have no performance or cooling issues with LR 7.2, but find it a useful time-saver in my workflow. I only need to "build previews" one (1) time after editing. YMMV.

                                 

                                paulwieczorek  wrote

                                 

                                Thank You for the advice with LR 7.1, it's def operating better in terms of performance. I've recorder a video while editing photos where I check temps from time to time - if You would be interested, here's the link (scroll through the slow parts): Dropbox - LR_temps.mov

                                LR 7.1 looks much better. Adobe is aware that the changes made in 7.2 are causing issues such as what you're experiencing. I suggest continue using 7.1 for now and wait for 7.3 before updating.

                                 

                                paulwieczorek  wrote

                                 

                                Also I've done additional tests on max spec iMac 5K 27" (late 2015) and the idle temps are around 37-40*C with many apps opened, while when importing and building 1:1 previews at the same time, they go to 70*C-ish. Of course iMac has better spec and cooling.

                                 

                                The question remains - are the idle temps of our new MBP standard or should we replace it? *wondering*

                                MBP cooling fans and heatsinks are smaller and less efficient than what's used in the larger iMac system. The fans will be noisier and run at higher RPM doing the same tasks. You may want to have an Apple Tech Center look at your MBP with LR running and see what they think., but your video running 7.1 looks pretty normal.