9 Replies Latest reply on Jun 25, 2008 9:36 AM by Linux Rules

    Problem with installation

    george279
      Hello,

      I just downloaded Robohelp 7 (not the trial version) and I'm trying to install it on Windows XP Pro SP2. The file unpacks fine, then I run setup. I can select three items to install, a PDF application and two Robohelp applications. The PDF application installs fine, however, I get a Windows error message that msiexec needs to close with the typical "Send" "Do Not Send" to Microsoft buttons. The installer does not quit however, it continues and at the very end even says Robohelp was installed successfully.

      However, when I try to run any of the Robohelp icons on my desktop, I get an error message that says this application has caused and error and needs to close.

      I've tried uninstalling from Add/Remove Programs, this also caused the msiexec to crash. I also tried restarting setup and doing a repair, still no good, I did a remove, still no good.

      I opened a tech support call and manually deleted registry entries as per the technician's suggestion and manually deleted the Robohelp application from the hard drive. Still no good.

      This is a new installation of Windows XP and there's not much on the PC other than Office 2003.

      I also followed the instructions in this technote:

      http://kb.adobe.com/selfservice/viewContent.do?externalId=kb402652&sliceId=1

      Still no good.

      Might anyone have any idea what's going on here?

      Thanks
        • 1. Re: Problem with installation
          lmarden Level 2
          dumb question - you have full admin rights to install on your (local) computer, right? And you aren't trying to install to a network drive?
          • 2. Re: Problem with installation
            lmarden Level 2
            just did a search in the forums using keyword msiexec - it pulled up a discussion Peter had with another user about Silent Install. Nothing that seemed to apply here. Maybe when Peter sees this he can bring his brilliance to the table.
            • 3. Re: Problem with installation
              george279 Level 1
              Sorry forgot to mention that. I'm in the local administrators group on this PC. I unpacked the installation files to c:\robohelp. I am trying to install them to the local c: drive.
              • 4. Re: Problem with installation
                Linux Rules
                Hello george279 -

                Welcome! Sorry to hear about your problem. I can only ask and suggest a couple things...

                Did you run a checksum on the downloaded file? If so, did they match? If you didn't do a checksum then all else is troubleshooting blind.

                Did you have an active Internet connection during installation? You need it or there could be problems.

                Did you have an antivirus program running? If so that could be a problem as RoboHelp must write to the hard drive Master Boot Record - the only thing to do is reformat the MBR. Note: this could be a breeze or it could be painful. You may need your Windows installation CD (don't plan on this working from a "hidden" partition on your hard drive that contains your Windows install files - you may lose it - you need an install CD).

                Same thing if your motherboard has an antivirus "feature" to prevent writing to the MBR (such as some Dell computers, etc.) - you need to disable this in the BIOS before installing RH. Same situation re: reformat MBR.

                Regards,
                GEWB
                • 5. Re: Problem with installation
                  george279 Level 1
                  I just logged back in to Adobe and checked out my order. I don't see any checksum there to compare with what I'm getting. Maybe I'm missing something? I don't remember seeing it there to begin with, maybe it goes away once you've downloaded it?

                  Anyway, I tried installing it on a different PC and I got the same result.

                  I can try disable McAfee that I have running on my Dell PC, I wonder why it must write to the MBR though.

                  thanks,
                  George
                  • 6. Re: Problem with installation
                    george279 Level 1
                    Ah yes, I also have internet access on both PC's that I tried the installation on.
                    • 7. Re: Problem with installation
                      Linux Rules Level 2
                      Hello george279 -

                      Hmm, you're right I don't see a checksum...somehow I remembered one from last year...time to get my eyes checked. Try calling tech support and ask is they have a checksum for the download file.

                      You tried loading on two machines with no luck. Are they same manufacturer and same software load? Did you check your workstation BIOS to make sure it allows wrting to the MBR?

                      So, Internet connection is ruled out.

                      You asked:
                      "...why it must write to the MBR though."

                      I asked that and the Adobe reply was "to protect their intellectual property" (making sure you aren't a thief).

                      I see that trial versions aren't available right now (not until July 1) - you could try that route as a trial version can be upgraded to a paid version.

                      Regards,
                      GEWB
                      • 8. Re: Problem with installation
                        george279 Level 1
                        I ran a cksum on a Linux box on a copy of what I downloaded from Adobe. It came out with 439275672, perhaps someone could do this on their end real quick and match what I got in the meantime?

                        The two machines are both Dells, but the software that's on them is a bit different. The error messages came at the exact places on each machine though.

                        I'm going to try to download the installer again. Dell said there's nothing in the BIOS of either machine blocking the MBR and I also disabled my AV software on both machines during installation.
                        • 9. Re: Problem with installation
                          Linux Rules Level 2
                          Hello george279 -

                          Sounding more and more like a borked download file.

                          I had to ask about your hardware as some BIOS (including some Dell models) have the MBR write blocking feature.

                          What is the downloaded file name, date and size? If I have that version I can generate an MD5 checksum.

                          Regards,
                          GEWB