4 Replies Latest reply on Mar 22, 2018 7:06 AM by jerryp97433002

    Action Created is skipping a step

    jerryp97433002 Level 1

      I will do the best I can explaining this issue, new to Actions & have a few saved, however having trouble with one. Let me start by saying I do real estate photography & use Lr & Ps. The views are everything in the market I work in & a must have. (Example: interior living room or bedroom shot with exterior views) I take a room shot then and exterior shot & blend layers in Ps. The technique I use for getting the views is called doing a 'Window Pull', you over expose the 2nd shot with an intense flash then blend the two images in Ps using a layer mask & brush the views in selecting darken mode.

       

      I created 3 Actions (F2, F3, F4) for different image types & what I need to do, not one hat fits all: I created F2 to Align the images, pretty basic & easy, F3 still working on not finished just yet. F4 is where I am having a problem with the 'Brush Tool'. Here is what I created for F4, to select both images, align images, reverse top & bottom images, deselect the bottom image & select the top image & add a layer mask, set foreground color 'White', brush size, opacity, hardness, flow, & darken mode. It worked out perfectly & is a real step saver except for one thing. After selecting F4 I sometimes have to select 'B' for the brush tool then I can start painting in the views. If the last image I worked on was still set to use the brush tool then its not a problem but if I was using the Clone Stamp tool the action plays out but the Brush Tool is not selected, Clone Stamp tool is, that's what was used last so I have to hit the B-Key & then I start painting in the views. Hitting F4 then 'B' is not a deal breaker but not knowing why & how to remedy this is driving me crazy, I would like to know why & how to fix it. And by the way in case you were wondering the B-Key is selected in the Action I created.

       

      I saw a video on YT that said try not to select the tool with the mouse pointer sometimes it will not register. Ran into a problem using the mouse on the right side when moving images around trying to create the steps & layers. It did work but only on the images I selected at the time. The Action created saved the steps I created along with the file number & would not recognize the Action on any other imported images because they have a different file number, so I had to create the Action by using Ps shortcuts & it worked out just fine....except for this B-Key issue.

       

      Any help would be greatly appreciated, thanks for reading, hope to get some answers.....Jerry