7 Replies Latest reply on Jan 15, 2009 6:23 AM by hermi14

    Merged Projects Not Appearing in WebHelp TOC

    hermi14
      Following the instructions on the Grainge site, I created a merged project with the following folder structure:'

      BAM\parent --->parent project location
      BAM\Child\Project1 --->child location
      BAM\Child\Project2 --->child location
      BAM\Child\Project3 --->child location

      I added the metatag redirecting the first topic in the parent project to the default topic in Project1.

      When I generated the output:

      I got a nested set of navigation frames along with the error msg from IE saying it blocked the content from running ActiveX.

      The correct TOC books, one for each project, did display in the outer navigation frame. However, once I clicked to allow the content to run, the TOC would disappear. When I went to IE Tools, Options and selected to allow ActiveX to run from My Computer, the error message stopped appearing, but the TOC disappeared entirely.

      I did get the extra set of nav frames to disappear by clearing the nav option in Project1 when I generated it.

      Thanks for any tips.





        • 1. Re: Merged Projects Not Appearing in WebHelp TOC
          Peter Grainge Adobe Community Professional
          It sounds like you have pointed the redirect to the start page rather than the default topic.

          The Active X warning is because you are viewing locally without Mark of the Web applied. You can either apply the mark or allow Active X to avoid the warning. On the server, you will not get the warning.

          • 2. Re: Merged Projects Not Appearing in WebHelp TOC
            hermi14 Level 1
            Even when I point the redirect to First_Topic.htm instead of parentprojectname.htm, I still don't get any books representing the child projects in my TOC.

            I do know the merged project feature is working b/c I can call a specific topic in one of the child projects by pointing to the parent project and using a map ID from one of the child projects.

            • 3. Re: Merged Projects Not Appearing in WebHelp TOC
              Peter Grainge Adobe Community Professional
              Take a look at the article on merged webhelp on my site. Maybe that will highlight something.

              The test of whether the merge is working is if the TOC and the index are OK. You have defined the TOC for the child project in the child project? I have seen people try to create it in the parent!

              Post back if no progress.


              • 4. Merged Projects Not Appearing in WebHelp TOC
                hermi14 Level 1
                OK, my bad. The parent project is grabbing the TOCs I define in the child projects.

                What confused me was that the first time I generated the parent project and the child projects, but before I had defined any TOCs anywhere (either in the parent or the children, except of course for the merged project entries in the parent TOC), I was seeing, for a brief split-second, a book displayed corresponding to each *project.* I don't know what that was, but I thought it was by design.

                PS I have already been using the article on your grainge site as my main source of information.
                • 5. Re: Merged Projects Not Appearing in WebHelp TOC
                  hermi14 Level 1
                  Hello. I have been sailing along working on my merged projects, but then I decided to change the name of one of them--twice. The first time I changed the name it continued to work fine. But this morning I changed the name again and now the child project no longer appears in the merged TOC.

                  **This is the first merged project in the parent project's TOC. However, it still doesn't appear even if I move it farther down in the list.

                  **The redirect from the parent project's default topic to the child project's default topic works fine.

                  **The child project's TOC works fine when I generate it independently.

                  **I changed the Title of the project and the name of the project. I regenerated the parent project to get the new folder name and generated the child project into that new folder name. Perhaps I did all of these things in the incorrect order? At first I didn't change the folder name, but then later I did. And I deleted the old output folder...

                  **The new project is being pointed to in the parent project's cshdat_robohelp.htm file (though interestingly there is no order to the list of child projects in that location).



                  • 6. Re: Merged Projects Not Appearing in WebHelp TOC
                    MergeThis Level 4
                    You have succeeded in totally confusing the RH parent project (as well as most of us ).

                    In the parent project TOC, delete that child merge indicator and re-insert it fresh.


                    Good luck,
                    Leon
                    • 7. Re: Merged Projects Not Appearing in WebHelp TOC
                      hermi14 Level 1
                      Thanks--I had deleted and readded the project a couple of times. What it took was regenerating the child and then the parent a couple of times over. I'm not actually sure what the fix was, but it eventually appeared.