3 Replies Latest reply on Apr 16, 2018 12:40 AM by HothWampa

    Spaces process still up to no good.

    HothWampa Level 2

      Every time I panned my canvas it was like a slide show, never understood why because it's been like that for so long I just though I had to deal with it.

       

      Alas, today, looking at Task Manager with Photoshop open I see 3 Spaces process running and remembered it was causing issues for people before (I think it was crashes on opening or was it brush lag? Anyway...) I right clicked, opened file location and put a tilde (~) in front of it as per the recommendation in the other thread. Lo and behold, my canvas now pans around like butter. Once again, disabling that process improves Photoshop performance. What's going on with Spaces?

       

      I also tried disabling the 50 CEPengine processes to see that would help performance too but my Extensions didn't load, so I guess not

       

      Ah well, just a fyi in case anyone else has horrible panning.

        • 1. Re: Spaces process still up to no good.
          JJMack Most Valuable Participant

          I have no problem panning also do not see any Spaces Processes running.  I also have change my Photoshop Preferencs setting from some of Adobe default. I turn off things like rich tips disable some cursor things do not use generator plug-in or sync to the cloud  use my workspaces and do not install Lightroom.

          cc2018Preferences.jpg

          1 person found this helpful
          • 2. Re: Spaces process still up to no good.
            Ged Traynor Adobe Community Professional

            Spaces Helper.exe was introduced in Photoshop CC2017 and removed in CC2018

            Try going to Preferences > General and uncheck Show Messages, restart Photoshop

            1 person found this helpful
            • 3. Re: Spaces process still up to no good.
              HothWampa Level 2

              Sorry for the late reply. Had to re-install Windows (not because of this ).

               

              After a fresh install of everything there are still 3 Spaces Helper.exe running when I use Photoshop but this time they aren't causing panning to be effected and brushes feel smoother too. There must have been something wrong with my Windows or Photoshop. I'm fairly sure I know the culprit that caused it.

               

              Thanks for the suggestions JJMack and Ged. I'll leave PS as is for the time being because it's running great but if I get any problems later I'll start tinkering.

               

              Cheers.